How to do USB audio playback on WP7607 modem


I am using WP7607 module and able to do USB audio record with audacity without any issue.But, at the time of doing the playback of recorded file, it throws error as:
“Error while opening sound device. Please check the playback device settings and the project sample rate.”

Do anyone know how can I do playback of recorded USB audio files?
Thanks a lot



Not sure what you want to do, you want to play the file through the WP76 from your host processor?



Hi Matt

Yes. Normally the wireless module has audio calls record and playback feature. Sierra old modem MC7304 also has this. But, some how the sample WP7607 modem, can do only audio record but when I play the recored audio, it gives error. This can be easily tested and reproduced using Audacity tool

  1. Install and open Audacity tools and select WP7607 audio driver
  2. Open the modem AT port
  3. Do a CS MT call to this modem and pick the call using ‘ata’ at command
  4. Record the audio using audacity tool --> works fine
  5. Stop the recording
  6. Playback the recorded file. It does not work



So you are saying that the audio is not coming through correctly or the file is not being recorded properly?

The MC7304 and the WP76’s are not comparable at all, different families, chipsets, age, code base, etc.



I confirmed that record is fine. If I play recorded file using MC7304 driver, or any player using default alsa driver. I can listen the sound. The issue is if I select WP7607 driver for playback, this gives error as shown in attached file. This confirms that the issue is on WP7607 playback only

I saw the same problem on playback in Audacity.
Don’t know why.
But I used arecord or aplay commands, they are working fine.

arecord -r 8000 /home/owner/Downloads/record.wav
aplay /home/owner/Downloads/record.wav

Thanks for the reply. aplay and arecord is working for me too. I am still not able to figure out what is the problem with Audacity play. I tried choosing different sample rates in audacity still no success


no idea, but at least proven that the USB audio is working fine, just not fully compatible with audiacity.