Getting Internet access for Linux host through MC8305


#1

I am working with an embedded Linux host running a network application that works fine using a cabled Ethernet connection for Internet access (through DSL or an external 3G router). I want to make it work mobile without the external 3G router, by using the MC8305 installed in a PCI Express Mini Card socket on the device. I can see that the modem is connected by USB, create a COM port device (/dev/ttyUSB2), and send it AT commands with microcom. I have a SIM card from Wyless (T-Mobile service) installed, and can read it like this:

AT+CIMI
31026076564xxxx
AT+ICCID
ICCID: 8901260762256xxxxxx

In the past I have used a MC5728 (CDMA) modem and been able to use “ATDT#777” to make a data connection (using a chat script) and use pppd to create the network interface. But in this case I get:

atdt#777
NO CARRIER

If there is no SIM card installed, it returns “ERROR”, so that is progress :slight_smile: But I now need to know how to take the next step. I think I might need some combination of:

  • Do GSM registration
  • Set up the APN
  • Dial

I see lots of postings in the Sierra forums about how to do networking using Open AT, but I am not looking to run an application on the modem itself, just use the modem as a modem. Could someone suggest what the next steps I need to take might be? Is using ppp the best option, or is there a more direct way to get a Linux network interface device? Is this the best forum to ask these questions in?

Thanks,
Steve


#2

Hi Steve,

Seems like you are using T-Mobile SIM, I think it is GSM/UMTS operator but can you please confirm with operator?

If that’s the case, ATDT#777 is mainly for CDMA network so it is expected to get “NO CARRIER” in your test. (GSM/UMTS network use ATD99**1# command)

Kindly test by sending ATD99**1# or change to correct command in PPPD script, you may also like to change APN setting as required by the SIM/operator by using AT+CGDCONT command.

From T-mobile website, http://support.t-mobile.com/docs/DOC-1979, the APN setting is:

Thus, you may try

AT+CGDCONT=1,"IP","epc.tmobile.com"
ATD*99***1#

Hope it helps.
Thx


#3

Thanks a bunch. I think I have another issue now, but that got me going on the right road.

Steve