FX30S - All APPs and services stopped running


Just wanted to ask a question about some behavior I’m seeing on my FX30s modem. About four different occasions already I have found all the APPs and services on my FX30s stopped running. Currently, I don’t have any explanation as to why this is happening. If I reboot the modem, all starts working again.

I captured the syslog, but it doesn’t seem to show when the problem occurred, or what the cause was. I have attached the syslog below. Any suggestions on how I can troubleshoot the cause or if you’re familiar with this scenario, please let me know. Thanks!



fx30s-logread.zip (50.9 KB)

The issue happened again last night. Here’s a more complete logread trail:

fx30s_9-23-20.zip (184.1 KB)

Hi Eddie,

From fx30s_9-23-20.zip, boot loop is detected during bootup so Legato framework (also the apps) not run.

Would you check is your FX30S rebooting or power cycle/interruption several time to face this problem?

Enabling developer mode could disable boot loop detection feature:

Or below old post for related discussion:

Hope it helps.

Thanks Louis,

I don’t see any reason why it would be rebooting, but will keep checking.

I’m using a FX30S LTE-m (WP7700). I have tried installing the devMode app in the past, but it never has worked. I’m using the Windows Developer Studio ver 5.3.1 to develop my app, and every time I connect to it to the modem, I get the message “devMode is not installed on the device. Some features will be disabled until you install it” When I try to install it from DS, a message pops up “Install devMode has encountered a problem/Cannot find any framework with devMode update file”

In you second link about “Disable boot loop detection”, it mentioned a manual correction if devmode not working. I tried rm /legato/bootCount but with no success.

root@fx30s:~# rm /legato/bootCount
rm: can’t remove ‘/legato/bootCount’: No such file or directory

Any other suggestions? Thanks!!


Hi Eddie,
For bootCount file, it only available during boot, i.e. it is cleaned if system run normally for ~1min.
That is if you don’t check within early boot (1st min), then likely you cannot find it, but you can find the info in logread message.

About devMode app, sorry that I don’t have FX30S LTE-m and not using DS actively, probably other members can help on that, but I think DS is fading out…

Still, I think you may also check/monitor does system ever reset/power cycle in your setup.

Hope it helps.

Hi Louis,

Thanks for your help, I’ll keep troubleshooting.

Can you tell me what development platform you’re using. I’m thinking is time for me to switch from DS to whatever is most current. Thanks!!


Hi Eddie,

The currently supported is Leaf and VSCode IDE (as plugin), as mentioned:

Also, nice preview post by Sarra:

Have fun!


Thanks for the information!

I found this code in the devMode.c on the boot-loops.

// Mark next reboot as expected to avoid false-positive detection of boot loops that can occur
// if the developer is repeatedly testing system behavior after reboots.

If I add this line of code to my app, will it work just like having devMode installed?



Hi Eddie,
Yes, you can use le_framework_NotifyExpectedReboot() as it is available since Legato 18.x.
I would suggest to make sure calling it at early system boot up, especially before any abnormal reset happens, otherwise the bootCount would just increment.


Hi Eddie,
To debug why your system is boot looping, perhaps you can look at the kernel logs when the actual crash occurs.
Enable console logs on the serial port by:
Now you should be able to view the kernel logs at 115200 via the DB9.