Firmware-Upgrade for EM7565 with Ubuntu

I thought so too, but ttyUSB2 is the only port i can access via minicom. Either way it hasn’t worked yet

after you enter AT!BOOTHOLD in minicom via /dev/ttyUSB2, the module will reboot.
After that, do you see /dev/ttyUSB0?

Well, before i enter at!boothold via USB0, the window opens but you can’t type anything, via USB2 you can type commands as usual.
After at!boothold, usb2 is not accesable anymore. usb0 opens but you still can’t type anything.
When i checked ls /dev/mh* , there is nothing found. Does that have something to do with the error?

AT!boothold should be entered in /dev/ttyUSB2
After module reboot, there will only be /dev/ttyUSB0, and then you should run the fwdwl-litehostx86_46 program

Thank you for your help but it still didn’t work. At least there is a new line indicating that the Donwload process startet: Downloading: Images(folder with firmwarefiles)/SWIX…
but the error code is: eSDP_FWDML_ERR_FIREHOUSE_STATE_ERR(120)

Did you install the mbpl usb driver?

Sorry for the late respone and thanks again. There were some drivers missing but i installed them now.
The download process progressed now for one more line : " downloading: Images/SWIX…zip
Still i got another error: "eSDP_FWDML_ERR_FIREHOUSE_DEV_REPORT_ERR(121)

Why do you download zip file
What is the exact command you entered

In fact the same as above, only with USB0 and cdc-wdm0

How about this

sudo ./fwdwl-litehostx86_64 -F -d /dev/ttyUSB0 - p /dev/cdc-wdm0 -w NameofCWWE-file.cwe -n NameofNVU-file.nvu

so just removing the FW-path? I tried, it seems that this is an essential parameter , so it didn’t work
Is there a command to check if all drivers are installed, although i think that it should be fine.
Or might it be something with the kernel-version? I’ve got a 5.4.x kernel

How about this

fwdwl-litearm -d /dev/ttyUSB0 -p /dev/cdc-wdm0 -t 1 --modelfamily 4 --fwpath "./" --cwe SWI9X50C_01.14.03.00.cwe --nvu SWI9X50C_01.14.03.00_TMO_002.005_000.nvu

Thanks, I’ve got a 64_x86-System so that is not so easy, there is always the exec format error but i will try

still don’t quite understand you will have a zip file inside:
downloading: Images/SWIX…zip

Yeah, me neither. It actually came once, after installing the drivers, now it isn’t occuring anymore

What is the log now?

I’ve attached the log file.
logfile.txt (49.9 KB)

could it be that the kernel aren’t installed?

I can see

[188][7]Firmware Write Completed

Btw, why didn’t you add “-t 1 --modelfamily 4”

you`re right, but the firmware hasn’t changed unfortunately.
Yeah i forgot that, but in the readme it says that this isn’t necesarry, i’ll try that