Error in web UI when changing edge actions

When changing any edge action, either in the code, or just by disabling it, I get this error.
With no extra info. All my code changes since last save are lost when this happens.

It seems to happen on all devices in my fleet, including the one I tried to delete from Octave and add again.

Has anyone else experienced this and found a solution?

BR Jes

I am still unable to make any changes to edge actions on any of my devices. This is really bad. Just when I thought that we were over the worst bugs in the Octave system this happens.

Hello Jes,

I have tried to replicate this issue on multiple devices and in multiple Octave accounts and cannot replicate this issue. Are your still experiencing this issue?

If so, could you invite me to your account and can I use a device to replicate this issue?

Hi @jj1 , the edge actions appear to define objects with duplicate properties, which is considered as invalid by the API only recently. We’ll shortly update the UI to point users to those duplicate properties.

In the meantime, I encourage you to use the “Format” button at the bottom left to align those properties and making it easier to spot duplicates.

CleanShot 2021-12-06 at 17.56.04@2x

Hi David,

Thanks, the problem was indeed due to an object with duplicate properties. Without your help I would have had close to no chance of figuring it out, as there was no indication that it was my code that triggered the problem.

The UI just discarded my code changes, and not even the part with bad object as that was present in the last saved version. Please take care not to discard users’ changes and in case of syntax errors etc. save it as a draft or similar.

Hi @jj1,

We just deployed the fix that shows those duplicate keys.

Indeed, we will fix this shortly as well.

Thanks a lot for reporting those issues. :pray:

1 Like