EM91 5G SA connection issues with mbim


i follow the following steps to connect to a PDN on 5G SA simulator with EM91: (Linux SDK (EM9190) - Application Developer’s Guide_R12_T (1).pdf)

sudo mbimcli -d /dev/cdc-wdm1 -v -p --set-radio-state=on

sudo mbimcli -d /dev/cdc-wdm1 -v -p --connect=apn=internet,ip-type=ipv4,session-id=0

This sequence works perfectly in 5G NSA but not in SA.

In SA, we are not able to connect to our internet apn.

We notice that in this case the modem always use the context 1 in AT+CGDCOUNT whatever the apn provided in mbimcli command.

In our case, by default, the context 1 was set to an ims. When we call the “sudo mbimcli -d /dev/cdc-wdm1 -v -p --connect=apn=internet,ip-type=ipv4,session-id=0”, the PDU session establishment request us done with ims instead of internet.

It is very strange, could you please provide us some support ?

does it work using the MBPL \SampleApps\lite-qmi-connection-manager ?

I don’t know. But it does not work with mbim and qmi.

you can try with that sample application, i remember it can choose profile ID

At this stage, i would haved like to make it work with mbim at minimum.

The integration is working pefectly with 3G, NSA, we have this issue only with SA.

my product is in operation, i can not change the way to integrate the modem.

Do you have any idea ?

No, i don’t, that is why i suggest to try sdk to see if there is any clue

Btw, have you tried to change at!imstestmode

Lastly, have you tried ipv6?

i have removed ims from CGDCOUNT by an another one. In this case the other one is used. It is not ims or ip related.

The key point is that the apn used as a parameter in connect request in mbim and qmi is not considered. The one considered is always the one in Context 1.

This behavior is only in 5G SA.

Can you confirm this behavior in your side ?

then why don’t you just set profile 1’s APN to “internet” by AT+CGDCONT?

The modem is offering interface and it does not work.

You want me to workaround without confirmation that the issue is confirmed on modem.

Morover, with this workaround, we are not able to manage multiple session which is not acceptable.

I need you to confirm the issue in the modem and to help us to characterize the workaround and the associated limitation.


i am not sure if you are doing the right thing…
On my side, for data conection, i am always using the same APN between mbimcli and AT+CGCONT.

maybe you can try only with MBIM as explained in your manual, removing the context 1 with AT+CGCONT. We could have the same behavior.

What is the purpose of this?
It seems not to be appropriate to set blank apn by the following?

The goal is to check you are e able to connect to the apn you set with the mbim command as explained in your reference manual.

To be sure to be connected on the apn you set on mbim command, you set either the APN in context 1 to NULL, or a default apn different the one you want to connect.

You call the command and you check if you are connected an if your IP address is the one corresponding to your APN.

In my case, using the mbim command, i connect to the apn in context 1 (if null, the default attahc one) so the and not the one on the command. The IP address is not the good one.

the purpose is to check that with your sdk is working or you have the same behavior as me.

I don’t have 5G SA network here, so not able to test for you on 5G SA connection.
Since you say only 5G SA has problem, you might need to contact distributor on this for the testing

Or you can just directly use same APN in data connection and AT+CGDCONT.
(normally i will use this method)