EM7430 LTE Registration Issues


#1

I have an EM7430 module that I am trying to connect to my LTE eNodeB but it is instantly detaching itself after connecting.

I have added the PLMN using the !NVPLMN command. I then ran AT+CFUN=1 to enable full functionality.

To connect I used the AT+COPS=1,2,ABCDEF,7 command to force an attach where “ABCDEF” are the 6 digits of my PLMN. However, the response I get is error 30 (no network service) when I run that command.

Running AT+COPS=? returns:
+COPS: (1,“ABC DEF”,“ABC DEF”,“ABCDEF”,7),(0,1,2,3,4),(0,1,2)

Looking from the eNodeB side, the EM7430 registers and establishes an RRC connection, but then instantly detaches itself. The MME shows a Detach Request of type 3 from the EM7430 which indicates a “Combined GPRS/IMSI detach.”

Is there some AT command I’m missing here? The eNodeB and EM7430 are definitely seeing each other and communicating, but it doesn’t stay registered for more than 1 second. I know the eNodeB works and I tried the same set of commands on another EM7430 with the same results.


#2

So is this a test EnodeB and you have confirmed that the security keys between the SIM and the MME are correct?

Can you send the following to the unit

ati
at+cgdcont?
at!gstatus?
at+cmee=1
at+cops=1,2,"ABCDE",7

From what you have said above I do not expect it to change anything or give a different code but its something to try.

What we really need is a dmcapture log file to see the interaction between the module and the network. Dmcapture is a bash script which loads a filter file onto the unit through its DM port (/dev/ttyUSB0) and then records the output which (with QC tools) can then be decoded later. You can get the script from the QMI SDK (you do not need to be running QMI for this).

https://source.sierrawireless.com/resources/airprime/software/linux-qmi-sdk-software-latest/

I have attached an example of running the script, its old but the principle remains the same.

dmcapture example.txt (4.4 KB)

Regards

Matt


#3

Hello Matt,

Thanks for looking into this! This is a test eNodeB and I have ensured the security keys are correct on the SIM. I tried placing the SIM into a different company’s module and it works fine.

I have collected the dmcapture.raw file after running those commands you suggested. Can I decode it myself or should I post it here for you to look into?


#4

William,

You are going to need to post it here (or at least a link) for me to decode it.

Regards

Matt


#5

I sent you a private message with the log.