Ed_err_stack_bad_config


#1

Hi All,

I am getting a ED_ERR_STACK_BAD_CONFIG when I create a socket in a project that used to work fine. All I have changed is the data handling routines so I can’t imagine what I could have broken. The docs seem a little thin on reasons for the error.

The eDLib initialises fine and I only attempt to create the socket after ED_OK_GPRS_SESSION_SET.

Anyone got any ideas?

Kind regards,
Mike


#2

Hello [color=blue]Mike,

I don’t recognize this behaviour so I don’t have too many ideas but anyway, I give it a shot:

A bit too simple but the question needs to be asked:
What is the result of the ed_SocketSetConfig() routine?

Have you tried to close down Open AT application and erase all flash objects and applications? (Maybe there’s still something configured in the IP lib flash objects thats corrupting the settings)

/Snoooze


#3

Hi Snooze / All,

I must sheepishly admit during some coffee induced bit of inadvertent keyboard slapping I managed to delete the line that set the server IP of the socket connection… It was alittle way up in the code so I only picked up when I started taking the code back several permutations :slight_smile:

Thanks for the thoughts!


#4

Hello
I’ve the same problem “ED_ERR_STACK_BAD_CONFIG” when trying to set email config with some application (that send email)

I don’t understant because whith the same module, and the same edlib, when i have tried whith an other application that send also email, i’ve not any problems

Thanks for your tries to help me. :slight_smile:


#5

Hello,

Before I was trying to use UART2, but it didn’t work. I decided then to make FTP work.

I get ER_ERR_STACK_BAD_CONFIG (-12) error when trying to get a file from a FTP server.
Using the same module, I can send a file to this same FTP server.
The file I’m trying to get has the same filename of the file I put before.

What’s wrong with TCP-IP configuration?

Functions ed_FTPSetConfig, ed_FTPGetFileSetConfig returned 0 when called.

I’m using OpenAT 655_09gg.Q2501B 2015268 111705 17:01, and gcc compiler with Visual C++

Alex Teixeira Benfica
dcc.ufmg.br/~benfica