Download debug traces


#1

Hiya,

I’m trying to download the debug traces from a Q2686(G) using the adl backtrace analysis functions (as per section 3.12 of the ADL user guide).

I can never get a valid handle from adl_errStartBackTraceAnalysis() function - I always get a return of -1 (ERROR: an unexpected internal error occurred).

The BUG sample has the same problem - adl_errStartBackTraceAnalysis() always returns -1 - even after I force an exception using the AT+BUG=n command.

Has anybody else seen this? Can any of the Wavecom Dev’s enlighten me here? I’m attempting to do it this way, as M2M Studio doesn’t download the first section of the RTK status dump after an exception - so I don’t even know what kind of exception happened!

This is driving me mad. Any suggestions of other assistance would be greatly appreciated.

Of course, the next issue is to play back the downloaded traces…

CPU: Q2686G
OS: R7.3
Dev: M2M Studio 1.0.2

ciao, Dave


#2

I assume that davidc has long forgotten about this, but I thought I’d post my experience for posterity: I had the same problem davidc describes and contacted Wavecom. The Wavecom FAE who helped me didn’t know what he was doing, but in the process of debugging I called adl_errEraseAllBacktraces(). After that, adl_errStartBackTraceAnalysis() returned 0 and worked from that point on. The Wavecom FAE couldn’t explain why it worked, but I assume that the backtrace memory was corrupt and needed to be wiped clean before it could be used again. This could have been caused by the fact that I had recently upgraded from 6.63b10 to 7.1b (Q2687) and the bacetrace memory format is different.