Cannot find the MBPL source code and doc

I want to use the EM7345 and EM7455 on a Fedora distribution, so I wanted to install the MBPL package for Linux available on this link:

The Software Integration and Development Guide states that the driver should contain the source code, the binaries and the instructions on a readme.txt file, however I can only find the binaries. Do you know where I can find the instructions and the source code?

you can see this :

Thanks. I was not able to follow steps 6 and 9 because I run Fedora, but now I can see the modem through the network settings.

However, when I try to connect, I have a gsm-registration-timeout error, do you know any reason why?

Did you check “at!gstatus?” Of your module?

I get an error:

/dev/ttyACM0 is not AT command port
It should be /dev/ttyUSB2

Indeed, but I get this message when I try to connect with Minicom through /dev/ttyUSB2:

I assumed it was ttyACM0 that was working because dmesg | grep tty gives me:
when I connect the modem.

Sorry but I am very new to all of this ^^

The serial port should be enumerated by qcserial driver …
Did you compile and install the driver?

Yes, I compiled the MBPL R20 USB driver:

It seems that the EM7345 doesn’t work with this driver.

However, I just tried with the EM7455, and I can use the /dev/ttyUSB2 port. I get this:

You might try Gobiserial driver,-d-,42n2,-d-,64/

This modem is a bastard. It looks like an Intel modem with a Sierra label,. And it is only ever sold as part of laptops. It has never been available in the embedded - small system integrator - market. Support is provided exclusively by the laptop vendors using the modem.

You can obviously not use any Qualcomm specific drivers or software like MBPL with this modem… It is based on an Intel XMM7160 chipset.

The default configuration is MBIM, and it will work with the cdc_mbim driver and associated userspace tools like ModemManager etc.

@dl5162: thanks, I’ll stop using the EM7345 and focus on the EM7455.

@jyijyi : with the Gobiserial driver, I have:

If I let ModemManager handle the connection, I see that the modem cannot register in a 3GPP network. I have:

which eventually ends in

This happens with both the Gobiserial and the MBPL drivers.

The problem is that it cannot register network.
Is your SIM card working fine?

It works fine when I put it in my phone, but I haven’t tried with other modems

what is the return of the followings?

Why your sim is not registering lte network?

You also need to check if the band is supported

The band B3 is used, and it is supported by the EM7455.

How can I find why my sim is not registering to the network? It’s working well when I use it with my smartphone.
Maybe the signal strength is not high enough for the antennas of the modem. I’ll try in another location in a few days

I solved the problem by moving to a location with a higher signal strength.
Thanks for the help @jyijyi !