Bearer start problem


#1

hi,

when ever i start the bearer using “wip_bearerStart” it returns the error code as “WIP_BERR_OK_INPROGRESS” for long time , so how can i solve this issue with return value as success.

please help me out.


#2

Hi,
which module are you using? also on which firmware version are you facing this issue?
Also make sure your module is registered to the network.

Regards,
Alex


#3

am using Q2687RD FW 7.52 i already registered to network but i unable to start the bearer quickly (its giving WIP_BERR_OK_INPROGRESS for long time). so how can i resolve this issue.

please help me out this problem.

thank u.


#4

Hiya,

A few things to check:

  1. Are you sure that your SIM card/service is enabled for GPRS data?
  2. Are you using the correct APN, username and password?
  3. Can you ensure that you are not roaming onto another network (and if you are, that you have data service on the roaming network)
  4. If the SIM is a pre-paid sim, do you have credit available?

ciao, Dave

ciao, Dave


#5

How long is “long time” :question:


#6

Hi, I am facing issue with opening any bearer(UART Bearer, GSM, Ethernet bearer etc).
/* Open the UART bearer */
bearerRet = wip_bearerOpen ( &br, PPP_BEARER, cbEvhBearer, NULL );

It is returning -44. I dont know -44 does mean.

I got to know that To open, configure and start the related bearer first the driver has to be registered with the wip_drvSubscribe () API. But i did not get any information regarding this API wip_drvSubscribe ().
Please let me how to subscribe to driver and how to open bearer. Thank you.


#7

/* Initialize the stack */
ret = wip_netInitOpts ( WIP_NET_OPT_DEBUG_PORT, WIP_NET_DEBUG_PORT_UART2,
WIP_NET_OPT_END ); //SUCCESS

/* Open the UART bearer */
bearerRet = wip_bearerOpen ( &br, “UART2”, cbEvhBearer, NULL ); //SUCCESS

bearerRet = wip_bearerSetOpts ( br,
WIP_BOPT_IP_ADDR, localAddr,
WIP_BOPT_IP_DST_ADDR, destAddr,
WIP_BOPT_IP_SETDNS, FALSE,
WIP_BOPT_IP_SETGW, TRUE,
WIP_BOPT_RESTART, FALSE,
WIP_BOPT_END ); //SUCCESS

bearerRet = wip_bearerStart(br);
bearerRet is returning WIP_BERR_OK_INPROGRESS. Please give me some suggestions it would be really help to me.


#8

Are you having errors when you create an account?