Mangoh UART communication issue

This forum has moved to http://forum.legato.io

Mangoh UART communication issue

Postby niladrireva » Wed May 25, 2016 2:15 pm

Hi
I am trying to use Mangoh Serial console port to communicate with my serial device. I have fired AT!MAPUART=17,1 to disabled Linux console and enabled application console . In my application i am writing data to the serial port "ttyHSL1" and i am able to print data to the serial port but my problem is, still i am getting linux console output from this uart which is creating problem in my serial slave device. Please help me on this.

Regards
Niladri
niladrireva
 
Posts: 3
Joined: Thu May 12, 2016 9:43 pm
Has thanked: 0 time
Have thanks: 0 time

Re: Mangoh UART communication issue

Postby rio99 » Wed May 25, 2016 3:49 pm

Hi Niladri

Serial console output on DB-9 is connected to UART2, so you should use AT!MAPUART=17,2.

Regards,
Igor
rio99
 
Posts: 7
Joined: Tue Apr 12, 2016 11:48 am
Has thanked: 0 time
Have thanks: 0 time

Re: Mangoh UART communication issue

Postby niladrireva » Wed May 25, 2016 4:13 pm

Hi,
Thanks for your quick response.
Yes now Linux console is completely disabled even my application console too.
Now I cant able to print any data from my application over "dev/ttyHSL1".
Any more suggestion.

Thanks
niladrireva
 
Posts: 3
Joined: Thu May 12, 2016 9:43 pm
Has thanked: 0 time
Have thanks: 0 time

Re: Mangoh UART communication issue

Postby rio99 » Wed May 25, 2016 4:29 pm

There is several ways you can access console, via USB or Ethernet:
ssh root@192.168.2.2 (suggesting you use USB-ECM)

If you had mixed console/application output, doing AT!MAPUART=17,2 should bring you app output/input only.
rio99
 
Posts: 7
Joined: Tue Apr 12, 2016 11:48 am
Has thanked: 0 time
Have thanks: 0 time

Re: Mangoh UART communication issue

Postby niladrireva » Wed May 25, 2016 4:55 pm

Hi
Yes i do not have problem with USB ECM. I can able to use SSH properly.
but after firing AT!MAPUART=17,2 i cant able to see any data at DB9 from my application also (don't know why).
Whats wrong am i doing?
but in the mixed console i can able to see my app data along with linux console.

Regards
Niladri
niladrireva
 
Posts: 3
Joined: Thu May 12, 2016 9:43 pm
Has thanked: 0 time
Have thanks: 0 time


Return to Legato Application Framework -- MOVED TO FORUM.LEGATO.IO

Who is online

Users browsing this forum: No registered users and 1 guest