Legato 14.10 released

This forum has moved to http://forum.legato.io

Legato 14.10 released

Postby amitchell » Wed Nov 05, 2014 5:19 pm

Hi everyone.

We have now released the 14.10 version of Legato. The links on the Dev Zone at http://developer.sierrawireless.com/landing/legato have all been updated to point to the new downloads, and github has been updated with the new source and documentation.

You will find the documentation online at http://www.legato.io/docs

Release notes and upgrade instructions can be found at http://www.legato.io/legato-docs/14_10/ ... _beta.html

Watch out for the new Developer Studio release which is imminent and will support development of Legato apps on Windows hosts for the first time.

The Legato Team

IMPORTANT: If you pulled our code before 3pm PST on 5th November you will need to do a "git pull" and then a "git pull --tags". We originally pushed the wrong version but it's now up to date.
User avatar
amitchell
 
Posts: 69
Joined: Wed Dec 03, 2008 4:09 pm
Location: Richmond, BC
Has thanked: 0 time
Have thanks: 15 times

Re: Legato 14.10 released

Postby awneil » Wed Nov 05, 2014 8:08 pm

Is there a USB stick image for that :?:
When I say "SiWi", that's short for "Sierra Wireless".
User avatar
awneil
 
Posts: 6641
Joined: Mon Dec 03, 2007 1:18 pm
Location: Basingstoke, UK
Has thanked: 54 times
Have thanks: 88 times

Re: Legato 14.10 released

Postby amitchell » Wed Nov 05, 2014 10:29 pm

Hi Andy,

probably not, but the developer studio release which is coming will remove the hurdles to getting going. It takes care of installing what you need and keeping things up to date.

Regards,
Andrew

For this post the author amitchell
has been thanked by :
awneil (Wed Nov 05, 2014 11:10 pm)
User avatar
amitchell
 
Posts: 69
Joined: Wed Dec 03, 2008 4:09 pm
Location: Richmond, BC
Has thanked: 0 time
Have thanks: 15 times

Re: Legato 14.10 released

Postby awneil » Wed Nov 05, 2014 11:11 pm

I'll look forward to that...

:D
When I say "SiWi", that's short for "Sierra Wireless".
User avatar
awneil
 
Posts: 6641
Joined: Mon Dec 03, 2007 1:18 pm
Location: Basingstoke, UK
Has thanked: 54 times
Have thanks: 88 times

Re: Legato 14.10 released

Postby s1nndev » Mon Nov 10, 2014 12:47 pm

Hello everyone,

I've installed legato 14.10.0 and wanted to install these packages in Developer Studio. But there always appears the following message:

'Installing packages' has encountered a problem.
An internal error occured during: "Installing packages".
index=0, size=0

If I create and run apps through the terminal, it works, so I think the legato toolchain and framework are installed correctly.
Can someone help me with this "Installing packages" issue?
Here are some more information to this error:

org.eclipse.emf.common.util.BasicEList$BasicIndexOutOfBoundsException: index=0, size=0
at org.eclipse.emf.common.util.BasicEList.get(BasicEList.java:346)
at com.swi.spm.legato.model.lpkg.util.LegatoPackagesHelper.parseExportedImportedAPIs(LegatoPackagesHelper.java:91)
at com.swi.spm.legato.model.lpkg.LegatoPkgDelegateMethods.handleSamples(LegatoPkgDelegateMethods.java:221)
at com.swi.spm.legato.model.lpkg.LegatoPkgDelegateMethods.handleAPI(LegatoPkgDelegateMethods.java:168)
at com.swi.spm.legato.model.lpkg.LegatoPkgDelegateMethods.handleMetadataGeneration(LegatoPkgDelegateMethods.java:470)
at com.swi.spm.legato.model.lpkg.LegatoPkgDelegateMethods.legatoOSPackageImportEngine_importPackage(LegatoPkgDelegateMethods.java:87)
at com.swi.spm.legato.model.lpkg.impl.LegatoOSPackageImportEngineImpl.importPackage(LegatoOSPackageImportEngineImpl.java:56)
at com.swi.spm.pluginmanager.PluginGenerator.generate(PluginGenerator.java:99)
at com.swi.spm.core.pkg.impl.LocalPathRepositoryImpl.install(LocalPathRepositoryImpl.java:118)
at com.swi.spm.pluginmanager.ui.actions.InstallPluginAction.install(InstallPluginAction.java:140)
at com.swi.spm.pluginmanager.ui.actions.InstallPluginAction.access$0(InstallPluginAction.java:106)
at com.swi.spm.pluginmanager.ui.actions.InstallPluginAction$1.runInWorkspace(InstallPluginAction.java:83)
at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:38)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)

Thank you!
Daniel
s1nndev
 
Posts: 28
Joined: Tue Jul 01, 2014 1:41 am
Has thanked: 11 times
Have thanks: 0 time

Re: Legato 14.10 released

Postby hbm_idneo » Mon Nov 10, 2014 4:50 pm

Hi everyone,

I have the same problem as Daniel.
Someone who shed light on this issue?

Thanks in advance.

Héctor
hbm_idneo
 
Posts: 6
Joined: Mon Jun 27, 2011 11:22 pm
Has thanked: 13 times
Have thanks: 1 time

Re: Legato 14.10 released

Postby s1nndev » Wed Nov 12, 2014 8:26 am

Hello everyone,

I have another problem since the update:
My voice call program always tries to connect to AirVantage. Before the update it worked well without it, and now it tries to connect and fails, then the program stops automatically.
Can someone tell me why I can't connect to AirVantage?
In the AT Command Port everything seems fine:

ati
Manufacturer: Sierra Wireless, Incorporated
Model: WP7102
Revision: SWI9X15W_06.03.27.00 r25145 CNSHZ-AR-BUILD 2014/10/23 06:28:13
MEID: 35560305000115
ESN: 12802438458, 8025353A
IMEI: 355603050001157
IMEI SV: 40
FSN: HM342500150703
+GCAP: +CGSM,+FCLASS,+DS

at!gstatus?
!GSTATUS:
Current Time: 837 Temperature: 25
Bootup Time: 6 Mode: ONLINE
System mode: GSM PS state: Attached
GSM band: GSM900
GSM channel: 72
GMM (PS) state:REGISTERED NORMAL SERVICE
MM (CS) state: IDLE NORMAL SERVICE

Serving Cell: 72 (GSM 900 )
RX level (dBm):-78.3125 LAC: 1C4C (7244)
GPRS State: GPRS STANDBY Cell ID: 00002C7F (11391)

at!custom?
!CUSTOM:
ISVOICEN 0x01
PCSCDISABLE 0x03
ADBENABLE 0x01
NOROAM 0x01
GPSENABLE 0x01
GPSSEL 0x01
CFUNPERSISTEN 0x01
NMEAENABLE 0x01
GOBIIMEN 0x01
HSICENABLE 0x01

I looked in the forum for help and found some methods that worked for others, but in my case they didn't work.

Thank you!
Daniel
s1nndev
 
Posts: 28
Joined: Tue Jul 01, 2014 1:41 am
Has thanked: 11 times
Have thanks: 0 time

Re: Legato 14.10 released

Postby daav » Wed Nov 12, 2014 8:42 am

s1nndev wrote:Can someone help me with this "Installing packages" issue?

Please note that a new Developer Studio release will be available very soon (a matter of hours), in order to be compatible with 14.10
Unfortunately there are some changes that are making DS 3.1 not compatible with 14.10 release.
Developer Studio dev team

For this post the author daav
has been thanked by :
s1nndev (Wed Nov 12, 2014 9:00 am)
User avatar
daav
 
Posts: 1202
Joined: Thu Oct 20, 2005 11:45 am
Location: Paris, France
Has thanked: 8 times
Have thanks: 87 times

Re: Legato 14.10 released

Postby esun » Wed Nov 12, 2014 7:13 pm

s1nndev wrote:Hello everyone,

I have another problem since the update:
My voice call program always tries to connect to AirVantage. Before the update it worked well without it, and now it tries to connect and fails, then the program stops automatically.
Can someone tell me why I can't connect to AirVantage?
In the AT Command Port everything seems fine:

ati
Manufacturer: Sierra Wireless, Incorporated
Model: WP7102
Revision: SWI9X15W_06.03.27.00 r25145 CNSHZ-AR-BUILD 2014/10/23 06:28:13
MEID: 35560305000115
ESN: 12802438458, 8025353A
IMEI: 355603050001157
IMEI SV: 40
FSN: HM342500150703
+GCAP: +CGSM,+FCLASS,+DS

at!gstatus?
!GSTATUS:
Current Time: 837 Temperature: 25
Bootup Time: 6 Mode: ONLINE
System mode: GSM PS state: Attached
GSM band: GSM900
GSM channel: 72
GMM (PS) state:REGISTERED NORMAL SERVICE
MM (CS) state: IDLE NORMAL SERVICE

Serving Cell: 72 (GSM 900 )
RX level (dBm):-78.3125 LAC: 1C4C (7244)
GPRS State: GPRS STANDBY Cell ID: 00002C7F (11391)

at!custom?
!CUSTOM:
ISVOICEN 0x01
PCSCDISABLE 0x03
ADBENABLE 0x01
NOROAM 0x01
GPSENABLE 0x01
GPSSEL 0x01
CFUNPERSISTEN 0x01
NMEAENABLE 0x01
GOBIIMEN 0x01
HSICENABLE 0x01

I looked in the forum for help and found some methods that worked for others, but in my case they didn't work.

Thank you!
Daniel


Hi Daniel,

Can you create a new topic for this issue?
What do you mean by "My voice call program always tries to connect to AirVantage"?
Can you also provide some logs (through logread)?
Finally on target can you check the status of your apps (root@swi-mdm9x15:~# app status).

Thank you and I will support you as soon as I can,
Enoch
User avatar
esun
 
Posts: 66
Joined: Mon Jan 13, 2014 9:23 am
Location: Vancouver, BC
Has thanked: 0 time
Have thanks: 21 times

fsn

Postby jasontang401 » Sun Aug 16, 2015 3:47 pm

fsn
Last edited by jasontang401 on Mon Aug 17, 2015 1:12 pm, edited 1 time in total.
jasontang401
 
Posts: 3
Joined: Thu Mar 21, 2013 9:12 am
Has thanked: 0 time
Have thanks: 0 time

Re: Legato 14.10 released

Postby davidc » Mon Aug 17, 2015 8:59 am

Hiya.

Legato doesn't run on the MC series modules, so this is the wrong topic for your module.

Also, please don't hijack an old thread with a question about a completely different topic. It makes it hard for members to make appropriate comments.

And this appears to be a duplicate of https://forum.sierrawireless.com/viewtopic.php?f=56&t=9025. Multiple posting doesn't help either...

Ciao, Dave
davidc
 
Posts: 1004
Joined: Mon Jul 14, 2008 5:14 am
Has thanked: 4 times
Have thanks: 59 times


Return to Legato Application Framework -- MOVED TO FORUM.LEGATO.IO

Who is online

Users browsing this forum: No registered users and 1 guest