[FXT009] baud rate and clock frequency problem

Open AT programmable FX009, FX100 and GL Series

[FXT009] baud rate and clock frequency problem

Postby noorc07 » Thu Oct 29, 2015 10:25 am

Hello guys,
i am working on a project which will collect several sensors data and send them work station via fxt009. I am facing problem with communicating fxt009 with AVR micro controller (Atmega32). however fxt009 is working fine with the pc via usb cable. i also checked the output signal from my micro controller and its working fine. but fxt009 is not responding, i am using a 8MHz crystal for the clock frequency and making the baudrate 115200 as this the default rate of fxt009. do i need a higher crystal? or Do i need any other chip to communicate with fxt009 with the microcontroller? as right now i am directly connecting the tx, rx of the micro-controller to rxd and txd of the fxt009.
i will highly appreciate if any body help me on this.
noorc07
 
Posts: 3
Joined: Sun May 31, 2015 1:07 am
Has thanked: 0 time
Have thanks: 0 time

Re: [FXT009] baud rate and clock frequency problem

Postby Rex_alex » Wed Nov 04, 2015 9:47 am

Hi,
How are you connecting the microcontroller and FXT009? Is it via UART?
Can you share the schematic diagram? if the connection is not proper, then there is a chance of communication failure.

-Alex
User avatar
Rex_alex
 
Posts: 1395
Joined: Thu Jan 01, 1970 12:00 am
Has thanked: 0 time
Have thanks: 84 times

Re: [FXT009] baud rate and clock frequency problem

Postby noorc07 » Wed Nov 04, 2015 10:04 am

Hello Alex,
I am connecting through 15-pin SUB-D serial interface connector. Attached is the schematic diagram of the connections.
Attachments
fx-uc.jpg
fx-uc.jpg (37.06 KiB) Viewed 1024 times
noorc07
 
Posts: 3
Joined: Sun May 31, 2015 1:07 am
Has thanked: 0 time
Have thanks: 0 time

Re: [FXT009] baud rate and clock frequency problem

Postby awneil » Wed Nov 04, 2015 12:43 pm

The FXT has a true RS232 interface; ie, with +/- 12V levels.
You should not connect this direct to a microcontroller - you must use an RS232 transceiver :!:
When I say "SiWi", that's short for "Sierra Wireless".
User avatar
awneil
 
Posts: 6636
Joined: Mon Dec 03, 2007 1:18 pm
Location: Basingstoke, UK
Has thanked: 54 times
Have thanks: 88 times

Re: [FXT009] baud rate and clock frequency problem

Postby noorc07 » Wed Nov 04, 2015 12:59 pm

awneil wrote:The FXT has a true RS232 interface; ie, with +/- 12V levels.
You should not connect this direct to a microcontroller - you must use an RS232 transceiver :!:

But in the datasheet of fxt009, its written input/output voltage is +/- 5v not "+/- 12v". please see the attached.
Attachments
fx_data.jpg
fx_data.jpg (182.5 KiB) Viewed 1015 times
noorc07
 
Posts: 3
Joined: Sun May 31, 2015 1:07 am
Has thanked: 0 time
Have thanks: 0 time

Re: [FXT009] baud rate and clock frequency problem

Postby awneil » Wed Nov 04, 2015 5:52 pm

But you still shouldn't be applying negative voltage to your microcontroller, and your microcontroller cannot generate the negative voltage.

Don't add unnecessary areas of doubt & uncertainty; do it properly - use an RS232 Transceiver :!:
When I say "SiWi", that's short for "Sierra Wireless".
User avatar
awneil
 
Posts: 6636
Joined: Mon Dec 03, 2007 1:18 pm
Location: Basingstoke, UK
Has thanked: 54 times
Have thanks: 88 times

Re: [FXT009] baud rate and clock frequency problem

Postby IanSiladi » Thu Nov 26, 2015 3:43 pm

Can you please post the schematic that you are using practically for your circuit?
Also what are all your hardware components?
Can you please share your interface and its components?
Also what are the components and the program(if you are using internal clock of AVR) for your clock frequency?
IanSiladi
 
Posts: 1
Joined: Thu Nov 26, 2015 7:30 am
Has thanked: 0 time
Have thanks: 0 time

Re: [FXT009] baud rate and clock frequency problem

Postby awneil » Thu Nov 26, 2015 6:41 pm

probably a bit late - as there has been no reply from the OP for nearly a month now ...
When I say "SiWi", that's short for "Sierra Wireless".
User avatar
awneil
 
Posts: 6636
Joined: Mon Dec 03, 2007 1:18 pm
Location: Basingstoke, UK
Has thanked: 54 times
Have thanks: 88 times

Re: [FXT009] baud rate and clock frequency problem

Postby viya0414 » Sat Dec 02, 2017 1:35 am

Can you share the schematic diagram? if the connection is not proper, then there is a chance of communication failure.
viya0414
 
Posts: 1
Joined: Fri Dec 01, 2017 5:33 pm
Has thanked: 0 time
Have thanks: 0 time

Re: [FXT009] baud rate and clock frequency problem

Postby awneil » Sat Dec 02, 2017 11:12 am

probably a bit late - as there has been no reply from the OP for over two years now ...
When I say "SiWi", that's short for "Sierra Wireless".
User avatar
awneil
 
Posts: 6636
Joined: Mon Dec 03, 2007 1:18 pm
Location: Basingstoke, UK
Has thanked: 54 times
Have thanks: 88 times


Return to AirLink Programmable Modems

Who is online

Users browsing this forum: No registered users and 2 guests