Not able to open USB port and UART 3

WIPlib and WIPsoft, TCP, UDP, FTP, SSL, HTTP, gateway services, …

Not able to open USB port and UART 3

Postby ganeshkimidi » Mon Aug 22, 2016 2:17 pm

Hi all,

AT+WMFM=0,1,1 // OK for enabling UART1
AT+WMFM=0,1,2 // OK for enabling UART2
AT+WMFM=0,1,3 // ERROR (USB port Not able to open)
AT+WMFM=0,1,5 // ERROR (UART3 Not able to open)

I am able to open UART1, UART2 & USB CDC ACM but i am not able to open UART3.
AT+WDSO=0,5 (Trying to open UART3)
+CME ERROR: 3

Please give me some suggestions, it would be really helpful to me.
Thanks
ganeshkimidi
 
Posts: 36
Joined: Thu Jun 23, 2016 10:48 pm
Has thanked: 0 time
Have thanks: 0 time

Re: Not able to open USB port and UART 3

Postby Rex_alex » Tue Aug 23, 2016 6:20 am

Hi,
Which module are you using? are you sure that particular module support UART3??

-Alex
User avatar
Rex_alex
 
Posts: 1382
Joined: Thu Jan 01, 1970 12:00 am
Has thanked: 0 time
Have thanks: 83 times

Re: Not able to open USB port and UART 3

Postby ganeshkimidi » Wed Aug 24, 2016 10:00 am

Hi alex,
Thanks for response. I am working on SL8082BTA module. But i am not sure UART3 will support or not. But i got to know from sierra docs, UART3 is not supported to SL8082T.
ganeshkimidi
 
Posts: 36
Joined: Thu Jun 23, 2016 10:48 pm
Has thanked: 0 time
Have thanks: 0 time

Re: Not able to open USB port and UART 3

Postby Rex_alex » Mon Aug 29, 2016 6:00 am

Hi Ganesh,
Yes, as per PTS, UART3 is not supported in SL8BTA.

-Alex
User avatar
Rex_alex
 
Posts: 1382
Joined: Thu Jan 01, 1970 12:00 am
Has thanked: 0 time
Have thanks: 83 times


Return to TCP/IP, Internet and Security libraries

Who is online

Users browsing this forum: No registered users and 3 guests