HTTPS issue since apache 2.4.10-10+deb8u8

WIPlib and WIPsoft, TCP, UDP, FTP, SSL, HTTP, gateway services, …

HTTPS issue since apache 2.4.10-10+deb8u8

Postby CBaudouin » Tue Apr 04, 2017 12:09 pm

Hello,

I am developing an HTTPS client on the ST8082TR chip. I experienced problems when connecting to Apache HTTPS servers since version 2.4.10-10+deb8u8 or 2.2.22-13+deb7u8.

The reason is that since this update, the Apache module reqtimeout is enabled by default. The Open AT Application does not have sufficient time to connect before apache respond with 408 code: timeout.

To bypass this, the server has to be configured with a greater timeout. In /etc/apache2/mods-available/reqtimeout.conf, line 19, replace
Code: Select all
RequestReadTimeout header=20-40,minrate=500
with
Code: Select all
RequestReadTimeout header=40-60,minrate=500


I hope that can spare you some debugging time.

Have a nice day !
CBaudouin
 
Posts: 6
Joined: Thu Mar 16, 2017 8:25 am
Has thanked: 1 time
Have thanks: 0 time

Return to TCP/IP, Internet and Security libraries

Who is online

Users browsing this forum: No registered users and 1 guest