No target management devices DS 3.6 (SL6087)

Developer Studio, Discovery Tool, Watcher

No target management devices DS 3.6 (SL6087)

Postby speranskiy » Fri Aug 19, 2016 9:06 am

Hi there!
Could you please assist me to get everything working?
I run Arch Linux. My SL6087 is being added as /dev/ttyACM0
Code: Select all
crw-rw---- 1 root dialout 166, 0 Aug 19 12:00 /dev/ttyACM0

initially it has been belonging to uucp group, but I use udev rule to change the group to dialout.
Also I saw the same issue here and tweaked /var/lock folder permissions so my user has r/w right to it.
Code: Select all
ls -la /run/lock
total 4
drwxrwxr-x  5 root lock 120 Aug 19 12:00 .
drwxr-xr-x 22 root root 620 Aug 19 11:00 ..
-rw-rwxr--  1 root lock  22 Aug 19 09:13 asound.state.lock
drwxrwxrwt  2 root lock  40 Aug 19 09:13 dmraid
drwxrwxr-x  2 root lock  40 Aug 19 09:13 lockdev
drwxrwxr-x  2 root lock  40 Aug 19 09:13 subsys

The user belongs to "lock" group (plus uucp and dialout
Code: Select all
gid=100(users) groups=100(users),3(sys),5(tty),6(disk),7(lp),10(wheel),14(uucp),54(lock),90(network),91(video),92(audio),93(optical),95(storage),96(scanner),98(power),108(vboxusers),1000(dialout)

I'm able to connect to SL using minicom and to send AT commands but there is no any traces of the device in Target Management.
Seems like it's just Java doesn't see the device. I have rxtx-java installed though.
I know that DS supports Debian based distros only, but nonetheless, could you please help me out with the issue?
speranskiy
 
Posts: 2
Joined: Wed Sep 10, 2014 12:42 am
Has thanked: 0 time
Have thanks: 0 time

Re: No target management devices DS 3.6 (SL6087)

Postby speranskiy » Fri Aug 19, 2016 9:17 am

I've added missing packages via the Packages Manager
Image
Eventually I do see the device but it fails to connect with error
Code: Select all
Open and load local port ttyACM0 => ERROR: Success
Open and load physical port ttyACM0 => ERROR: Success
Open port ttyACM0 => ERROR: Success
Wait for USB port to reconnect => NO NEED TO DO IT: Success
Open port ttyACM0 => DONE: null
gnu.io.NoSuchPortException
Pause : 1000 milliseconds => ERROR: Success

Am I still missing something?
speranskiy
 
Posts: 2
Joined: Wed Sep 10, 2014 12:42 am
Has thanked: 0 time
Have thanks: 0 time

Re: No target management devices DS 3.6 (SL6087)

Postby daav » Mon Aug 29, 2016 7:57 am

Unfortunately, USB support was never that good on Linux hosts for Open AT devices.
If possible, you should give a try and switch to a UART or USB/UART converter interface instead.
Developer Studio dev team
User avatar
daav
 
Posts: 1199
Joined: Thu Oct 20, 2005 11:45 am
Location: Paris, France
Has thanked: 8 times
Have thanks: 87 times


Return to Development tools

Who is online

Users browsing this forum: No registered users and 1 guest