SL8082T blocked and not responding

Developer Studio, Discovery Tool, Watcher

SL8082T blocked and not responding

Postby CBaudouin » Tue Mar 21, 2017 4:33 pm

Hello,

After having downloaded my own custom OpenAT program to the chip, it seems the SL8082T (in a Maestro Wireless M100 3G device) is blocked on a semaphore (error in the code). I cannot connect to the device through the serial port /dev/ttyS0. I get no response. Unplugging and replugging the device seems not to help.
Is there a procedure to reinitialize totally the chip ?

I have seen here: https://forum.sierrawireless.com/viewtopic.php?f=108&t=8126&hilit=semaphore that DWLWin could help me on that issue. Is the program compatible with my device ?

Thank you.
CBaudouin
 
Posts: 6
Joined: Thu Mar 16, 2017 8:25 am
Has thanked: 1 time
Have thanks: 0 time

Re: SL8082T blocked and not responding

Postby mlw » Wed Mar 22, 2017 4:45 pm

Hi,

No DWLWin is not compatible with your unit, this is only for the old 2G ST based units.

You need to contact your distributor as there is a program around I think that can stop the application running by putting it into boot mode on power up through the USB.

Regards

Matt

For this post the author mlw
has been thanked by :
CBaudouin (Thu Mar 23, 2017 8:50 am)
mlw
 
Posts: 664
Joined: Thu Jun 17, 2010 3:59 am
Has thanked: 0 time
Have thanks: 64 times

Re: SL8082T blocked and not responding

Postby CBaudouin » Thu Mar 23, 2017 8:49 am

Hello,

Thank you for your answer

I managed to resolve this problem. The AT command would not respond to commands like AT+WOPEN=0. But I found that the command AT+WDWL would be the only one to actually work. I sent the bootloader and firmware through XMODEM-K1 https://mycusthelp.net/SIERRAWIRELESS/_cs/AnswerDetail.aspx?sSessionID=&aid=487. The device is now functional again.

Thank you.
CBaudouin
 
Posts: 6
Joined: Thu Mar 16, 2017 8:25 am
Has thanked: 1 time
Have thanks: 0 time


Return to Development tools

Who is online

Users browsing this forum: No registered users and 2 guests