WS6318 - Echo / feedback


#1

Hi there,

we have some challenges with our settings to avoid echo / feedback once the mic is connected to our pcb. Individually both (mic / speaker) work fine but we have been trying already 3 days without any improvement. in our previous module everything worked fine.

Does anybody have sample / best practice configurations for a smart watch?
Does anybody provide consultancy in that case - actually it should be a Sierra Topic but since we outsourced the production it is difficult to get the right person at Sierra.

Thankful for any help / advice,
Felix


#2

Hi,
What exactly is the issue you are facing and what are the settings you tried so far?

-Alex


#3

Hi Alex,

thanks for your response. We are experiencing a loud echo on the far end side.
So far we tried various values for the ecL Filter Length and the ecFE_SpeechDelay but without any noticeable improvements.
Sometimes the echo seems to be a little bit cut off or off higher frequency. With low values for the speech delay high frequent artifacts seem to be introduced.

We also tried increasing the ecMux values with noticeable but not good results for ecMu0 > 0xC350 and ecMu1-3 increased as well. With these values the echo becomes heavily distorted but not reduced.

Do you have a best practice/Guideline for which values to increase/reduce to mitigate the echo?

Something like: if the echo sounds more high frequent, try increasing value xyz in steps of 5 until… Then start manipulating value abc …

Thank you,
Felix