Windows 10 has problem with "wwan card to USB adaptor(mc7430 )" when has a lan connection

I run into a weird issue. I have a windows 10 mini-PC. I connected a WWAN card via USB. The WWAN card has MC7430 chip. The card can be seen below. Windows mini-PC can surf internet without any issue. So far so good.
The problem arises when I connect a laptop to my mini-PC via ethernet. Laptop and mini-PC can communicate. But mini-PC loses its internet. By losing internet, I mean mini-PC cannot use WWAN interface. Here is the ping output.

c:> ping -t
pinging with 32 bytes of data
PING: transmit failed. General failure.
PING: transmit failed. General failure.
PING: transmit failed. General failure.
I try to ping WWAN interface IP, again I get “transmit failed. General failure”

Its not a routing issue. Route table indicates wwan card is the gw. “General failure” clearly depicts a TCP/IP stack issue. As soon as I disconnect lan cable, issue resolves. Once I put ethernet cable back, issue arises.

*I installed windows 7 to mini-PC. Issue resolved. But I need to have it work with windows 10.
*I reinstalled wwan card drives. No help. I tried to update drivers, windows says it the latest drivers.

Whats wrong with windows 10 with mc7430 when LAN is connected?
It seems wwan card cannot be used along with a lan connection in windows 10.
any hint will be appreciated.