UE Attach with sierrawireless modem wp7608


#1

Hi,

we had the mangOH board with wp7608 modem , we would like to perform the UE attach with the local base station.

The base station is generating the signal for Band 3.

so i have a basic questions in relation to this topic

  1. We would like to use the different sim card that supports the epc provider. So, Is the modem supports the different simcard ?
  2. if yes to the above , then could you please provide the AT COMMANDS to perfrom the cell search and do succesful UE ATTACH ?

Thanks,
Siva


#2

Hi Siva,

Refer to WP7608 PTS, it does support Band 3.

UE attach to network/base station is automatic assuming it can read the SIM card and has network coverage (just like our cellular phone).

In some case, we need to configure the network APN, i.e.
AT command:

AT+CGDCONT=1,“IP”,“carrierAPN” //carrierAPN is actual APN provided by your network SIM card
Legato tool:
cm data apn carrierAPN

But for debug purpose, you can check below AT cmd:

AT+CPIN?
AT+CGDCONT?
AT+CGPADDR
AT!GSTATUS?
AT+CREG?
AT+CGREG?
AT+COPS?
Let me know the return if failed to register.

Or you can use Legato command, “cm”.

Hope it helps.
Thx


#3

Hi lotam,

Thanks for your inputs and I appreciate the quick response.
let me try your suggestions and then provide you the update.


#4

Hi lotam,

We had a Cell ready transmitting with Band 3 LTE signal with bandwidth 20MHz. and we verified the setup with sucuccesful UE attach with the normal UE.

I had changed the apn using the cm data command. I changed the sim card provided by the epc vendor.
How ever, i dont see the sierrawireless has the ue attach succes.

Following are the output of the AT Commands
AT+CPIN?
+CPIN: READY
AT+CGDCONT?
+CGDCONT: 1,“IP”,“internet”,“0.0.0.0”,0,0,0,0
AT+CGPADDR
+CGPADDR: 1,0.0.0.0
AT!GSTATUS?
!GSTATUS:
Current Time: 239 Temperature: 31
Modem Mitigate Level: 0 ModemProc Mitigate Level: 0
Reset Counter: 1 Mode: ONLINE
System mode: WCDMA PS state: Not attached
WCDMA band: WCDMA 2100
WCDMA channel: 0
GMM (PS) state:DEREGISTERED LIMITED SERVICE
MM (CS) state: IDLE LIMITED SERVICE

	WCDMA L1 state:L1M_SUSPENDED    LAC:         7564 (30052)
	RRC state:   DISCONNECTED       UTRAN Cell ID:     0005C4B0 (378032)
	RxM RSSI C0:    ---             RxD RSSI C0:  ---
	RxM RSSI C1:    ---             RxD RSSI C1:  ---

AT+CREG?
	+CREG: 0,2
AT+COPS?
	+COPS: 0

AT+CGDCONT?

Could you please provide any debug AT commands to trouble shoot this UE Attach problem


#5

Hi Siva,
From log it seems SIM is working, but device searching for network and currently searching for UMTS band.
So, may just need to wait longer.

Or you may force it to scan only LTE band by below, please share the response.

AT!ENTERCND=“A710”
AT!BAND=?
AT!BAND?
AT!BAND=6 //set “0” to back to “auto” for all band

Thx


#6

Hi lotam,

please find the output of the at commands

AT!ENTERCND=“A710”
OK
AT!BAND=?
Index, Name, GW Band Mask L Band Mask TDS Band Mask
00, All bands 0002000000400180 0000018000000095 0000000000000000
01, Europe 3G 0002000000400000 0000000000000000 0000000000000000
03, Europe 2G 0000000000000180 0000000000000000 0000000000000000
05, GSM ALL 0000000000000180 0000000000000000 0000000000000000
06, Europe 0002000000400180 0000000000000085 0000000000000000
07, North America 0000000000000000 0000000000000010 0000000000000000
08, WCDMA ALL 0002000000400000 0000000000000000 0000000000000000
09, LTE ALL 0000000000000000 0000018000000095 0000000000000000

                                               0000010000000000 - B41
                                               0000008000000000 - B40
                                               0000000000000080 - B8
                                               0000000000000010 - B5
                                               0000000000000004 - B3
                                               0000000000000001 - B1
                              0002000000000000 - B8  (900)
                              0000000000400000 - B1 (2100)
                              0000000000000100 -     G900E
                              0000000000000080 -     G1800

OK
AT!BAND?
Index, Name, GW Band Mask L Band Mask TDS Band Mask
00, All bands, 0002000000400180 0000018000000095 0000000000000000

OK
AT!BAND=6
OK


#7

Sorry, Siva, my mistake.

Please set AT!BAND=9 to force it LTE only, so hopefully speed up the scan on LTE band.
(remind to set it “0” after test to set all band)

If still cannot register, even with good antenna and signal, please send below command and wait for response:

AT+CIMI
AT+COPS=?

This will scan and list all the operators and you should find the carrier name of your SIM… if not it means no signal from the carrier…

Thx


#8

at!band?
Index, Name, GW Band Mask L Band Mask TDS Band Mask
09, LTE ALL, 0000000000000000 0000018000000095 0000000000000000

OK

No, UE attach is not success.

AT+CIMI
001011234567094

OK
at+cops=?
+cops: (1,“Test PLMN 1-1”,“Test1-1”,“00101”,7),(3,“vodafone IE”,“voda IE”,“27201”,7),(3,“IRL - METEOR”,“METEOR”,“27203”,7),(0,1,2,3,4),(0,1,2)

at+cgatt?
+CGATT: 0

Test PLMN 1-1 ==> is the cell id to attach. But unfortunately its not attached

HOw to make forcefully to attach the above cell ?


#9

Hi Siva,

you could try to use AT+COPS=1,2,“00101”,7 for making the WP7608
use manual PLMN selection of your LTE test network.

If the UE attach still doesn’t work with that you would probably
need to look at NAS EPS and LTE RRC signalling traces to see at which
point the UE attach fails.

Regards,
Reinhard


#10

hi ,

we had tried the command and the below is the response

AT+COPS=1,2,“00101”,7
+CME ERROR: no network service

I had the wireshark log with attach reject. I ca share with you if you want more information.

Thanks,
Siva


#11

Hi Reinhard,

Please do find the wireshark log during attach.
In the wireshark frame, I see an Attach reject.
sierrawirless attach reject wireshark.7z (2.3 KB)

Is the modem locked to sierrawireless simcard ?
Could you please provide the next debug action to have the succesful UE Attach.


#12

hi,

we had tried with the standard sim provider from vodafone.
No succesful UE attach either with the standard network provider.
Below are the at commands output

at+cops?
+COPS: 1

at+cops=?
+cops: (1,"vodafone IE","voda IE","27201",2),(1,"vodafone IE","voda IE","27201",0),(1,"vodafone IE","voda IE","27201",7),(3,"IRL - METEOR","METEOR","27203",2),(3,"IRL - METEOR","METEOR","27203",0),(3,"3","3","27202",0),(3,"3","3","27205",2),(3,"IRL - METEOR","METEOR","27203",7),(3,"3","3","27205",7),(0,1,2,3,4),(0,1,2)
OK

at+cfun?
+CFUN: 1

at+cgatt?
+CGATT: 0

I had changed back to at!band=0 to support all the bands. Unfortunately, no luck with the UE attach.


#13

Hi Siva,

no, the WP7608 is not SIM locked. Otherwise it would not send out an
EMM attach to the network.

From looking at the S1AP trace one can see that there is an Authentication
failure (Synch failure) from the UE to the network after the
first Authentication request from the network to the UE and there is NO
Authentication response from the UE to the network after three
Authentication request messages from the network.

My suggestion would be to check that the authentication related parameters
for the test SIM used have been entered correctly in your test network.

It might also help to retry with the vodafone IE SIM after you have
set the parameters for data profile 1 back to the
defaults with AT+CGDCONT=1,“IPV4V6”,"" .

Regards,
Reinhard


#14

with the vodafone sim card, now looks to me, UE attach is success.
But not able to reach google dns server. I have configured the APN

Below are the details

t!gstatus?
!GSTATUS:
Current Time: 158 Temperature: 30
Modem Mitigate Level: 0 ModemProc Mitigate Level: 0
Reset Counter: 1 Mode: ONLINE
System mode: WCDMA PS state: Attached
WCDMA band: WCDMA 2100
WCDMA channel: 10737
GMM (PS) state:REGISTERED NORMAL SERVICE
MM (CS) state: IDLE NORMAL SERVICE

WCDMA L1 state:L1M_PCH_SLEEP LAC: 0BD5 (3029)
RRC state: DISCONNECTED UTRAN Cell ID: 000CA541 (828737)
RxM RSSI C0: — RxD RSSI C0: —
RxM RSSI C1: — RxD RSSI C1: —

Hope we are connected to LTE signal. what is that wcdma in the status message indicate ?

root@swi-mdm9x28:~# cm data
Index: 1
APN: live.vodafone.com
PDP Type: IPV4V6
Connected: no

root@swi-mdm9x28:~# cm radio
Power: ON
Current Network Operator: vodafone IE
Current RAT: UMTS network (LE_MRC_RAT_UMTS)
Status: Registered, home network (LE_MRC_REG_HOME)
Signal: Weak signal strength (2)
PS: Packet Switched Registered, home network (LE_MRC_REG_HOME)

How to get the data connection to live . Any help ?


#15

Hi Siva,

both AT!GSTATUS? and cm radio report that the WP7608 uses the vodafone IE
UMTS network. It you want it to only use LTE networks you would have to
switch it back to AT!BAND=9.

According to https://docs.legato.io/latest/toolsTarget_cm.html you would
have to use cm data connect to setup a data connection.

Regards,
Reinhard


#16

Hi,

I had verified the same test network setup with same authentication parameters with the two different UE’s and we had a succesful UE attach with both the phones.
How ever, we dont see the sierra wireless modem trying to register to the test network when we put back the same sim card in the sierra wireless modem. eventually NO UE Attach.
We are blocked on making progress to have an UE Attach with our test network. providing status of all the AT commands below

at+cgdcont?
+CGDCONT: 1,“IP”,“internet”,“0.0.0.0”,0,0,0,0

OK
at+cpin?
+CPIN: READY

OK
at+cgpaddr?
ERROR
at+cgpaddr
+CGPADDR: 1,0.0.0.0

OK
at!gstatus?
!GSTATUS:
Current Time: 552 Temperature: 35
Modem Mitigate Level: 0 ModemProc Mitigate Level: 0
Reset Counter: 1 Mode: ONLINE
System mode: WCDMA PS state: Not attached
WCDMA band: WCDMA 900
WCDMA channel: 2962
GMM (PS) state:DEREGISTERED LIMITED SERVICE
MM (CS) state: IDLE LIMITED SERVICE

WCDMA L1 state:L1M_PCH_SLEEP LAC: 7564 (30052)
RRC state: DISCONNECTED UTRAN Cell ID: 000523A1 (336801)
RxM RSSI C0: — RxD RSSI C0: —
RxM RSSI C1: — RxD RSSI C1: —

OK
at+creg?
+CREG: 0,0

OK
at+cgreg?
+CGREG: 0,0

OK
at+cops?
+COPS: 1

OK
at+creg=?
+CREG: (0-2)

OK
at+creg=2
OK
at+creg?
+CREG: 2,0

OK
at!band?
Index, Name
00, All bands

OK
at+cimi
001011234567094

OK
at+cops=?
+cops: (1,“Test PLMN 1-1”,“Test1-1”,“00101”,7),(3,“vodafone IE”,“voda IE”,“27201”,2),(3,“IRL - METEOR”,“METEOR”,“27203”,2),(3,“vodafone IE”,“voda IE”,“27201”,7),(3,“IRL - METEOR”,“METEOR”,“27203”,0),(3,“3”,“3”,“27202”,0),(3,“3”,“3”,“27205”,2),(3,“IRL - METEOR”,“METEOR”,“27203”,7),(3,“3”,“3”,“27205”,7),(0,1,2,3,4),(0,1,2)

OK
AT+COPS=1,2,“00101”,7
OK
at+Cops?
+COPS: 1

OK
at+cfi
ERROR
at+cfun?
+CFUN: 1

OK
at+cgatt?
+CGATT: 0
OK

root@swi-mdm9x28:~# cm radio
Power: ON
Current Network Operator: Test PLMN 1-1
Current RAT: LTE network (LE_MRC_RAT_LTE)
Status: Not registered and not currently searching for new operator (LE_MRC_REG_NONE)
Signal: Very strong signal strength (5)
PS: Packet Switched Not registered (LE_MRC_REG_NONE)

at!lteinfo
!LTEINFO:
Serving: EARFCN MCC MNC TAC CID Bd D U SNR PCI RSRQ RSRP RSSI RXLV
1575 001 01 12594 00000E06 3 5 5 27 52 -6.1 -84.2 -58.1 5

IntraFreq: PCI RSRQ RSRP RSSI RXLV
52 -6.1 -84.2 -58.1 5

InterFreq: EARFCN ThresholdLow ThresholdHi Priority PCI RSRQ RSRP RSSI RXLV
GSM: ThreshL ThreshH Prio NCC ARFCN 1900 valid BSIC RSSI RXLV
WCDMA: UARFCN ThreshL ThreshH Prio PSC RSCP ECN0 RXLV
CDMA 1x: Chan BC Offset Phase Str
CDMA HRPD: Chan BC Offset Phase Str

How to force the UE to register the test network and also how to disable/enable airplane modes

I tried with at+Cfun=4 and at+cfun=1 . But no luck , I dont see any wireshark traces indicating that UE trying to communicate with the EPC.

Please provide us your inputs.


#17

Hi Reinhard,

When I disable all the bands and to scan only lte band. The UE Attach is failure with the standard sim card with Vodafone network. where as the 3g network was success. I am providing the system status with the

root@swi-mdm9x28:~# cm data
Index: 1
APN: internet
PDP Type: IPV4
Connected: no
root@swi-mdm9x28:~# cm data apn live.vodafone.com
root@swi-mdm9x28:~# cm data
Index: 1
APN: live.vodafone.com
PDP Type: IPV4
Connected: no
root@swi-mdm9x28:~# cm radio
Power: ON
Current Network Operator: vodafone IE
Current RAT: LTE network (LE_MRC_RAT_LTE)
Status: Not registered and not currently searching for new operator (LE_MRC_REG_NONE)
Signal: Strong signal strength (4)
PS: Packet Switched Not registered (LE_MRC_REG_NONE)

AT!BAND=9
OK
ATZ
OK
packet_write_wait: Connection to 192.168.2.2 port 22: Broken pipe
stirulaka@ubuntu:~/work/mttm$ ssh root@192.168.2.2
root@192.168.2.2’s password:
root@swi-mdm9x28:~# microcom /dev/ttyAT

+CGREG: 0
AT
OK
AT+CGATT?
+CGATT: 0

OK
AT+COPS=?
+COPS: (1,“vodafone IE”,“voda IE”,“27201”,7),(3,“IRL - METEOR”,“METEOR”,“27203”,7),(1,“3”,“3”,“27205”,7),(0,1,2,3,4),(0,1,2)

OK
AT!GSTATUS?
!GSTATUS:
Current Time: 227 Temperature: 39
Modem Mitigate Level: 0 ModemProc Mitigate Level: 0
Reset Counter: 1 Mode: ONLINE
System mode: LTE PS state: Not attached
LTE band: B3 LTE bw: 20 MHz
LTE Rx chan: 1450 LTE Tx chan: 4294967295
LTE CA state: INACTIVE
EMM state: Deregistered Attach Needed
RRC state: RRC Idle
IMS reg state: No Srv

PCC RxM RSSI: -77 RSRP (dBm): -107
PCC RxD RSSI: -95 RSRP (dBm): -130
Tx Power: 0 TAC: 9858 (39000)
RSRQ (dB): -10 Cell ID: 07A2B102 (128102658)
SINR (dB): 13.2

OK
AT!SCACT?
!SCACT: 1,0

OK
AT+CGREG?
+CGREG: 1,0

OK
AT+CPIN?
+CPIN: READY

OK

We would like to have the sierrawireless modem to have the succesful UE attach with the lte network.


#18

Hi Siva,

my suggestion would be to do a cm radio off and cm radio on after you have set the correct APN for the network you want to use with cm data apn.
If you still can’t make the EPS attach work you might need other forms
of technical support as described here https://www.sierrawireless.com/company/contact-us/technical-support/ .

Regards,
Reinhard