RV50X Connectivity Troubleshooting

Hi, first time poster here,

I’m configuring a new RV50X and I’ve been having some connectivity issues with it. It’s got a confirmed functional Verizon SIM card in it and I can access the Acemanager interface just fine when connected via ethernet, but I’m unable to connect to it wirelessly. The “Network” LED light is green but “Signal” LED light is blinking amber. Any troubleshooting tips would be appreciated. What I’ve tried so far:

  • Same SIM/Antenna/Cable/Configuration with a different new RV50X – no issues
  • Updated ALEOS/radio module Firmware to 4.12.0
  • Restored to factory settings

Another note: upon reboot both the Network and Signal LEDs will occasionally be blinking red. Given time they will switch to green and blinking amber, respectively, but it can either take as short as a few seconds or up to 15 minutes. Has anyone experienced anything similar? Is this a hardware issue?

Any help is appreciated.

The “Signal” LED is blinking amber, it means that the signal is poor. Could you help to change antenna or move the gateway to another location?
And make sure that the firmware and Radio Module Firware are correct. They should be RV50 ALEOS 4.12.0.p31 and RV50X Radio Module Firmware for Verizon

And when the “Network” LED is green, gateway is registered to network successfully, please check RSSI,RSRP,RSRQ,SINR value?
If the SINR value < 6, the signal strength is poor.
If the configuration is correct, antenna is good, the network signal at that location is good but device receives poor signal, you can return this device for warranty.


Hi jerdung,

Thanks for the reply. The I’ve swapped out the antenna and I’ve moved the RV50 to several locations with still no luck. The ALEOS firmware and radio module firmware are up to date. I’ve isolated this behavior just to this modem, so I think the next step is to return it under warranty.

If you restored the settings to factory default, then the remote AceManager access is likely disabled, as that is the default out-of-the-box setting in the later ALEOS firmware versions.