Repartition wp7702

There is an older forum topic on this. But has anyone found a way to repartition the WP7702 to increase the size of the rootfs as of 2021? The AT!PARTITION is not supposed to work on WP77xx as per the AT command reference r8, but does show the partitions. Has anyone tried using this to change the partitions on the WP7702?


It says “By default, this command is not available. It is only available as a factory
(SKU-level) configuration.”

Have you tried to enter as the example?

You can also check if the command is already “disable”, if it is disabled, you cannot have partition change:

Purpose: Return the execution command format and the supported parameter values.
If !PARTITION is not enabled, the response will include “None/Not Allowed”
instead of a list of partitions.

Thanks for your response! When I try the command you suggested, I see the below.

To print partition table: AT!PARTITION?                                         
To modify partition sizes: AT!PARTITION=<name>,<size0>[,<size1>,...]            
  <name> - name of the first partition to modify its size, can be blank         
  <size0> - new size in KB of the first partition                               
  <size1>,... - new sizes of next partitions                                    
  for example: AT!PARTITION=0:boot,2560                                         
  List of partitions whose size can be modified:                                
            PART    BLOCK     SIZE                                              
            NAME   OFFSET     (KB)                                              
         0:aboot 00000249     1024                                              
          0:boot 0000024D    15360                                              
        0:system 00000289    30720                                              
       0:LEFWKRO 00000301     8960                                              
         0:SWIRW 00000324    25600                                              
       0:USERAPP 00000388   134144                                              
      0:RESERVED 00000594    55808                                              
To disable partition sizes change: AT!PARTITION=disable                         

So it does look like I can change the partition sizes. Is there any way to recover if I mess up the partitions?

Maybe you can try the example and see if you can change the legato partition