Package not providing libraries for active toolchain


#1

Hi all,

Environment
Module: SL6087
OS: Windows 10 64-bit
IDE: Developer Studio 2.3.2
Build Version: 2.3.2.201310241753
Open AT Framework Package: 2.37.0.201202280640
Open AT OS Package: 6.37.0.201202060950
Firmware Package: 7.47.0.201202010317
Security Plug-In Package: 1.5.0.201108111447
Internet Library package: 5.43.0.201202100610

Problem:
When I build I get errors from the Internet Library Package, Open At OS Package, and the Security Plug-in Package. All of these have the following error, "[Package Name] ([version]) is not providing libraries for the active toolchain: [Target] ARM EABI GCC.

What I Have Tried:

  1. Reinstalling Dev Studio
  2. Removing and the Open AT Framework Package and associated packages.
  3. Computer restarts at various stages of the two above.
  4. Running Dev Studio in compatibility mode
  5. Matching setting with another PC which works.

So far I have been unable to find and/or fix the cause of this problem. Does anyone have any advice on fixing this? If such a thread exists please point me to it. Thanks in advance for any help provided.


#2

Hi,
Did you check ‘paths and symbols’ section? (right click on your project and go to properties -> c/c++ general-> paths and symbols)
Add the include directories if not listed in ‘paths and symbols’.

-Alex


#3

Hi Alex,

Yes I did check the paths and symbols. I basically looked at the project settings on a working machine and ensured that they are present on this one. I Can’t seem to find any differences between the settings on both computers. However, the one computer is using windows 8 (working) and the new install is on windows 10 (not working). So far this is the only difference I can see. Beyond that I may have been installing something incorrectly, but from viewing the packages they seem to be identical to the working machine.


#4

can you share the screen shot of your dev studio set up?

-Alex