Null character sending problem through UART2 in SL6087

i’m recently started working on SL6087 module and presently i’m using UART2 in this module…

I’m trying to send data to the External MSP through UART2 using the below mentioned code and i’m not able to receive the same data at receiving end of MSP

ascii buff[]={0x69,0x03,0x02,0x00,0x20,0x00,0x25}; // sending data
adl_fcmSendData (uart2_fcmHandle,buff,sizeof(buff)); // API using for sending data

when i send this data i’m receiving only 0x69,0x03,0x02,0x20,0x25 only and missing 0x00,0x00 but i need those zeros also to fulfill my requirement…

Can you please help me on this ASAP…

Thanks & Regards

Well done - new thread!


Are you sure that the problem is in the SL6087 sending the NULs, or the “External MSP” receiving them :question:

Note: don’t assume that people are going to know what you mean by, “External MSP”

I’m sure that there is no problem in MSP because when i’m sending the same data through RS232 , all the data i’m able to receive including 0x00 also…so, i believe there is no problem for receiving 0x00 at receiving end of MSP…

Is there any data type declaration issue for sending data ? Presently i’m sending like below

u8 buff[8];
adl_fcmSendData (uart2_fcmHandle,buff,8);


Just as a thought, try using u8 as your data type (rather than ascii) as per the function definition

ciao, Dave

That did occur to me - but seems a bit unlikely?


That’s not what you showed originally - have you actually tried both?

Have you looked at the SL6087 output with an oscilloscope?

Have tried receiving from the SL6087 using some other device; eg, PC-based?

You still haven’t said what you mean by “MSP”…

Yes i have tested with both types but in both cases i’m not able to get 0x00…
I have tested in CRO also…
MSP is TexasInstruments microcontroller(MSP430F47187)…

Today I have tested with another GSM module by connecting it to PC through RS232 and i got another problem
when i’m sending one data from GSM module at my PC i’m getting another data like below mentioned
If i send 0xFF,0xFF,0xFF,0xFF , i’m getting 0x80,0x80,0x80,0x80

Is there any commands need to give for getting the data what i’m sending ?

Can you post the observed waveform?

Are you sure that your baud rates, etc, are correct?