MC7304 - failed to play any audio after long hours calls


I ran a call between MC7304 to another MC7304 using AT command. The call is set to 2 mins duration, after the duration is finished, it will wait 15s and call again.

I found that after 4 hours+, the MC7304 will not play any audio again - so the call becomes a silent call. The only way to fix this is by restarting the device, or if I run AT!Reset on the MC7304. I’m using driver 6.12.4277 with firmware version

Any idea what’s wrong with the MC7304?

Could you please explain a bit more about your use case so that I can test it at my end.
Is it like you are doing this test for continuous 4 hrs (calling for 2mnt, then wait for 15 sec, then call again…). if so how are you doing that? are you using any utility or application??


I did (or rather, programmers before me) it using codes written in C#. In background, what it does is essentially run the ATD, AT+CHUP, etc in a loop. Nothing special about this, you can do this manually if you can stand writing the same AT command repeatedly. Once call is established, I feed the audio through the PCM interface - so that the card will play whatever audio that is played by my source.

It’s weird, because after long hours call, I tried to play the audio out from the source and it’s still playing. I don’t have any equipment to test the MC7304, so I don’t know whether the MC7304’s audio in is the one that fails or is it the audio out that fails.

Anyone else has seen this same problem?

Don’t care about my custom code, it really is nothing. It just let the device to do call via AT, in a loop, and I set it to loop for really long time.


We have the same experience as you have.
We use MC7304 and USB audio interface. We use for recoding and playing audio wav files MC7304 sound USB audio interface.
We have firmware: SWI 9X.15C r26426.
We use following settings:



1.It has strange behavior we have to open and close window in control panel sound -> recording because after few calls from MC7304 we lost audio for playing audio wav file.
2.We have the same experience after approximately four hours we lost audio completely.
We do four hours calls every 5 minutes (one call has 40 seconds)
After four hours we lost audio completely. We tried restart modem through at command AT+CFUN=1,1 and AT!AVDEF however it didn’t solve problem with sound.
We have to shutdown PC.

Best regards Alan Sabo

I recommend you to contact your distributer and come via support front to get proper support for your case…