Linux QMI Driver Version S2.30N2.48: GobiNet compile fails


#1

Hello,

When compiling the GobiNet:

# tar -jxf SierraLinuxQMIdrivers.S2.30N2.48.tar.bz2
# cd GobiNet
# make

With this Linux QMI Driver:

https://source.sierrawireless.com/resources/airprime/software/usb-drivers-linux-qmi-software-s2,-d-,30n2,-d-,48/

I get these compile errors: (please see attached file, make-output.log.txt)

Thank you in advance for your help and time,
J
make-output.log.txt (9.95 KB)


#2

Hi,

Please try with this update in make file and check if it removes implicit declaration error…

KBUILD_CFLAGS += -Wno-error=implicit-function-declaration

If yes, you can try for other errors similarly by googling to remove other warning also.

Thanks and Regards,
Rex