Issue with stty config and reception of data in FX30


#1

Hello,

I have an issue with stty config and reception of data in FX30:

1- I send the data from my host : echo -ne “test\r” > /dev/ttyUSB0
2- I receive data in module side with: cat /dev/ttyHSL0
3- But for the first test ( first echo), I don’t receive “test” and some stty flags have changed in the module side ( like ixon - isig - opost) !!
4- i resend the data from my host : echo -ne “test\r” > /dev/ttyUSB0 == this time i receive the second “test” !!!

have you an idea for this behaviour?

Regard


#2

Hi MikeRose,
Could you please check your MAPUART setting. Ensure you have UART1 set to 17.

Have you configured your USB to serial adapter to send at 9600 baud? Perhaps the first message sent doesn’t get sent because the adapter is configuring auto-baud? The /dev/ttyUSB0 defaults to 9600.

Also, please execute the command without the -n and \r. I wonder if your USB to serial adapter may be causing issues. I have problem sending: echo -e “test” > /dev/ttyUSB0

BR,
Chris


#3

@cchenry,

Yes, now it works, but I don’t have HSL0 ! it replaced with HS0 !, I want to know please the difference between “Customer Linux application” & “Linux console” ??
Thank’s
Regard


#4

Hi Mike,
Both console and custom linux application use HSL0, could you please double check? HS0 should not be enabled.

The Custom Linux application is a mode that keeps the port open but does not provide the linux console. It allows your custom application to send data to the serial port. You cannot send any linux commands in this mode.

Linux console means that you can execute command line Linux commands, run scripts, etc.

BR,
Chris


#5

Hi @cchenry,

No, when I set UART1 to 17, I lose HSL0 and it becomes HS0 !! that’s why I have used 16 services just to have the HSL0. What is the difference between HSL0 (lite) & HS0 (Full)? it’s not the same drivers?
Please check if it is normal to lose HSL0 with “Customer Linux Application” or not! otherwise why in “Console Linux” I don’t receive the first echo and after I receive my all data? ( I’m sure to have the same TTY configurations ( in host and target)

Thank you very much for the explanations

Regard
Mike


#6

@MikeRose,

The Linux console is the actual Linux output of the core OS, where the customer Linux application is to allow the actual Legato application you are writing to use the UART.

Regards

Matt


#7

Hi Mike,
MAPUART mode 16 and 17 both use the same HSL0 driver. Could you please post the output of the following:
AT!FWD?ALVER
AT!MAPUART?

The HS0 driver supports full flow control and is only used for MAPUART=15, which is RS232 with flow control. The HSL0 driver supports both RS232 and RS485 and is used for MAPUART modes 14, 16 and 17.

When you have MAPUART =17,1, could you please check which devices are available?
ls /dev/ttyHS*

BR,
Chris