How to update legato framework on FX30s?


#1

Hi, I have update the FW on the above modem (to the latest version available) and was expecting the legato framework to also update to 16.10.3, but instead it is still 16.10.1

a) How do I update the framework?
b) Does it matter?
c) Why can’t I do all this through DevStudio?
d) When will the newer versions of legato be supported by FW packages and Dev Studio?

Thanks,

Karl


#2

Hi Karl,

You’re right, R13.1.3.001 still has Legato 16.10.1.

To answer your questions:

a) The framework could be updated if you install the 16.10.3 binary from the WP Source or legato.io. You would need to use fdt2 tool (Windows) or swiflash (linux)

b) You only need to update if there is an issue that is fixed, here’s link to the release notes:
legato.io/legato-docs/latest/rel … 16103.html

c) DevStudio is more of an IDE for creating Legato applications

d) A new FW release (supported by DevStudio as well) should be available in a couple of weeks

BR,
Chris


#3

Hi Chris, thanks for you reply… I will have a look at the changes…


#4

Hi @cchenry, just wondering what versions are now available from Sierra Wireless for the FX30S. Looking at the official download site (from the FX30 product page), it does not look like anything new has been released yet?

https://source.sierrawireless.com/resources/airlink/software_downloads/fx30-firmware/fx30-firmware/

Thanks,

Karl


#5

Hi Karl,
Officially, we’ve release the source code for R13.1.3.001 for the FX30S. You can find the link on the page that you’ve reference. This version uses Legato 16.10.1.

To clarify: here’s a summary of the FX30 source code that was released:
R13.1.3.E01 - This version was released as part of the legato-spm distribution. The source code was based off an engineering version
R13.1.3.001 - Available on the Source only, not included in legato-spm.

Soon to be released:
R14 - I apologize for the delay. I realize a long time ago I mentioned a new release would be available. We are hoping to have the binary image and the Source code available within a week from now. This version will contain a Legato maintenance branch based off Legato 16.10.3. (Software will report 16.10.1.m3 but this does not mean 16.10.1)

BR,
Chris


#6

Hi @cchenry, thanks for the reply. I see 16.10.1.m3 has been released. I presume 16.10.3 is the toolchain I should use to build for this version? The reason I ask is because I have updated my FX30s to 16.10.1.m3 and built my application using the 16.10.3 toolchain, but I am getting the

error, which else where on the forums is suggested is a version mismatch between the FW and toolchain? However I can’t find reference to the correct toolchain for 16.10.1.m3 on the Source.

Additionally I also get the mismatch error when installing the application using Developer Studio 5.3.

Thanks,

Karl


#7

Hi Karl,
Could you please try posting you question on the Legato forum? I’ll also ask internally, but I think you’ll get a response quicker.
BR,
Chris