Hl7692 not registered for 4g

This module is working for me 2G, but not working for 4G.

Can you tell any commands need to set.

Hi mallesha143,

Note that HL7692 supports LTE Cat-1 (B3, B8, B20).
Try to set module LTE only mode and test again:
AT+KSRAT=5 // LTE only

Hi sierra_klin2,

Thank you for your reply, actual we are using jio sim, the signal strength not getting see below commands;..

17-04-2019 10:27:17.390 [TX] - at+cops?

17-04-2019 10:27:17.404 [RX] - at+cops?

+COPS: 0,0,“IND-JIO”,7


17-04-2019 10:27:19.108 [TX] - AT+WMANTSEL?

17-04-2019 10:27:19.123 [RX] - AT+WMANTSEL?



17-04-2019 10:27:21.249 [TX] - AT*PSRDBS?

17-04-2019 10:27:21.264 [RX] - AT*PSRDBS?

*PSRDBS: 50339850


17-04-2019 10:27:23.484 [TX] - AT+KSRAT?

17-04-2019 10:27:23.498 [RX] - AT+KSRAT?



17-04-2019 10:27:25.921 [TX] - at+creg?

17-04-2019 10:27:25.936 [RX] - at+creg?

+CREG: 2,1,“FFFF”,“00532C23”,7


17-04-2019 10:27:27.905 [TX] - at+csq

17-04-2019 10:27:27.920 [RX] - at+csq

+CSQ: 0,5



From your log, HL7692 succeeds to regiseter 4G:
+COPS: 0,0,“IND-JIO”,7 //7: LTE

Yes, buy signal strength is 0 and 2 and 3 only…

If we placed AIRTEL SIM it is working, but when ever we place JIO it’s not working.

Hi mallesha143,

Please make sure the validity of the SIM card. Check with operator the band supported by the network.

Hi Sierra_klin2,

Thank you for your reply,

The JIO sim supported networks bandwidth’s are 850 MHz and 1,800 MHz, and the HL7692 supported 1,800 MHz bandwidth only. So i’m configured with that. see images.

But there is signal strength issue.

So now wt should i do…

I need help…





For LTE you can check wtih AT+CESQ for signal strength .
When you say signal strength is weak, but module can still keep a stable network registrations. So for your funtional test, it should not be a problem.

+CMGS fail to send the SMS is due to “0x1A”(Ctrl+Z) should be sent after “Hello”.


Thank you for your reply,

We solved the signal strength problem by replacing the antenna.


But the SMS problem was not solved.


We are facing the problem with c mux and this is not working in hl7692,
But it working in hl8518

Hi mallesha143,

For SMS failure issue, please enable AT+CMEE=2 to see the exact ERROR code. I suggest you use AT+CMGD=0,3 to Delete all read messages, and AT+CMGD=0,4 to Delete all messages from preferred message storage .

For MUX issue, please share with your AT log and MUX frame log.

Hi Sierra_klin2,

Thank you for your reply, SMS problem not solved by enter commands, but it is showing Capture

and for CMUX:

Do you have any software/tool for checking CMUX checking. If it is there can you share me file and it is very help to me…

Thank you