[HiLo] PPP Connection

I try to activate a PPP connection with an HiLo v2.

I can dial up with this sequence (this is a generic sequence for my program. ) :

After the CONNECT answer, I can initiate the PPP Link with the exchange of data for LCP, PAP, CCP and IPCP of the links layers.

When the link was established, I try to send an email. The problem is I can send IP frame but I don’t receive answer.
All the sequence is Ok (I have tried it with an other GPRS modem), but the Hilo v2 modem doesn’t want to work after the PPP link is established.

I suppose I don’t do something but I don’t know why.

Is anyone one can help me ?


After somme research, I has found my problem.

I’m not able to send UDP frames, so the dns resolution requests before a TCP connection fail.

If I use an IP adresse and not a name address, the TCP communication is ok.

Below, I copy an UDP frame for a DNS request.

Frame 41: 63 bytes on wire (504 bits), 63 bytes captured (504 bits) on interface 0 (outbound)
Interface id: 0 (RS232FULL)
Packet flags: 0x00000002
Encapsulation type: PPP (4)
Arrival Time: Mar 31, 2016 14:18:02.020000000 Paris, Madrid (heure d��t�)
[Time shift for this packet: 0.000000000 seconds]
Epoch Time: 1459426682.020000000 seconds
[Time delta from previous captured frame: 12.130000000 seconds]
[Time delta from previous displayed frame: 12.130000000 seconds]
[Time since reference or first frame: 375.730000000 seconds]
Frame Number: 41
Frame Length: 63 bytes (504 bits)
Capture Length: 63 bytes (504 bits)
[Frame is marked: False]
[Frame is ignored: False]
[Protocols in frame: ppp:ip:udp:dns]
Point-to-Point Direction: Sent (0)
[Coloring Rule Name: UDP]
[Coloring Rule String: udp]
Point-to-Point Protocol
Address: 0xff
Control: 0x03
FCS 16: 0x14ca [correct]
Protocol: Internet Protocol version 4 (0x0021)
[Direction: DTE->DCE (0)]
Internet Protocol Version 4, Src:, Dst:
0100 … = Version: 4
… 0101 = Header Length: 20 bytes
Differentiated Services Field: 0x00 (DSCP: CS0, ECN: Not-ECT)
Total Length: 57
Identification: 0x00bd (189)
Flags: 0x00
Fragment offset: 0
Time to live: 128
Protocol: UDP (17)
Header checksum: 0x9443 [correct]
[Source GeoIP: Unknown]
[Destination GeoIP: Unknown]
User Datagram Protocol, Src Port: 1032 (1032), Dst Port: 53 (53)
Source Port: 1032
Destination Port: 53
Length: 37
Checksum: 0x872b [correct]
[Stream index: 0]
Domain Name System (query)
Transaction ID: 0x0003
Flags: 0x0100 Standard query
Questions: 1
Answer RRs: 0
Authority RRs: 0
Additional RRs: 0
httpbin.org: type A, class IN

If someone have an idea for why UDP frames is not sent.


I found and solved my problem.

The server uses Xon/Xoff flow control, so when a UDP frame was issued, the Xon character was also issued.

I change my configuration and all is ok now.