FX30S run script when startup

Hello EveryOne
I have problem with FX30S moderm. I’ve already write some scrip have use “cm” commands. I want to put them in /etc/init.d folder to run when moderm startup. But it not run.
I was tried put script in /etc/rcS.d or rc0.d but It still not run when startup
Anyone who know how to put script to run when startup, please let me know

Hi there,
Could you please check a few things?

  1. Have you run your script manually and does it work?
  2. Have you made it executable?
  3. What you describe sounds like it should work. The script should be in /etc/init.d while a symlink to the script is in /etc/rcS.d. There are lots of examples in the directories already.

Alternately, you can follow the suggestions in this post and create a Legato application:



  1. Script well done when run manually
  2. I was used chmod +x script.sh to provide executable
  3. You mean script put in /etc/init.d then symlink to /etc/rcS.d use “ln” command. I was tried it with /etc/rc0.d but it not work
    Do you have anyway to do it?

Hi thre,
Try adding the symlink in /etc/rcS.d not /etc/rc0.d