EM7590 Manual Mode Persist after restart

Hi,

I have an EM7590 on an IOT device in an area that is getting a lot of noise from carriers within Canada and the US. The location is not well serviced so the device is connecting and dropping between multiple different carriers.

I want to force the device into manual mode doing something like this:

at+cops=1,2,“302780”

The problem is that it doesn’t persist. After a reboot/power cycle, the EM7590 goes back into Auto mode. How can I ensure that the manual mode setting persists after a restart?

How about using qmicli with --nas-set-system-selection-preference parameter?

https://www.freedesktop.org/software/libqmi/man/latest/qmicli.1.html

Hi,

I have not tried qmicli since I’m not that familiar with it. I installed it and tried to run a command against a ttyUSB device and I was getting the following errors:

qmicli -d /dev/ttyUSB0 --nas-get-signal-strength

-Warning ** [/dev/ttyUSB0] couldn’t detect transport type of port: unexpected port subsystem
error: couldn’t open the QmiDevice: Cannot automatically select QMI/MBIM mode

I tried this with the various USB devices with the same result.

I also tried this
root@AC-17191172:~# basename $(realpath /sys/class/usbmisc/cdc-wdm0/device/driver)
cdc_mbim

root@AC-17191172:~# qmicli -p -d /dev/cdc-wdm0 --wds-get-packet-service-status
[/dev/cdc-wdm0] Connection status: ‘disconnected’

how about using this?


sudo qmicli --device=/dev/cdc-wdm0 --device-open-proxy --device-open-mbim --nas-get-signal-strength