Does the WIP plugin activate a PDP context


#1

Hello,
I have found that a Q64 running with the WIP plugin is incurring higher than expected data charges. I have a monitoring/tracking application doing periodic uploads as a http POST. The GPRS is bearer is activated just before the POST and stopped following. The problem is there is a data charge as the machine starts up, (with AT+CALA…), before the GPRS bearer is activated and charges continue after the POST (and bearer stopped) at a rate dependent on the signal strength. In poor signal areas the minimum charge can be triggered as often as every 8 minutes! So the question is does the WIP plugin activate another PDP context automatically and leave it running for some reason? And can this this be turned off?


#2

What do you mean by that?


#3

like I get billed the minimum data charge ($.01)


#4

There can’t be a data charge before the GPRS bearer is connected, surely?! :open_mouth:


#5

seems to be! I will check some more


#6

There could be a data charge during the bearer establisment - but, before that, there is nothing over which data can be sent!


#7

yes this is why I ask is the WIP plugin doing something on it own? I’m definitely getting charges after stopping/closing the bearer. I also suspect it is happening before the bearer is opened but I have to check this. Trouble is web data charges are only available 2 days after the event.


#8

No, WIP itself doesn’t “silently” open or close bearers - so it cannot pass any data before a bearer is opened, or after it is closed.

Is it your own application?

You can check the states of GPRS contexts - including those managed by WIP - using the usual AT Commands…


#9

I have worked on this some more. I ran the application without it opening the bearer at all and got a 1c charge on start-up. To be sure I set the APN to an invalid name and got the charge!
I ran a SIM in a phone and there was no charge.
It does seem to be related to the provider (2Degrees, New Zealand), I ran a vodafone card and this does not happen.
The Question is what is the charge coming from?
I will test with the application stopped (wopen=0) and a non-WIP application.


#10

As it’s specific to the particular carrier, you’d have to ask that carrier.

You could try asking your local Distributor - they may be familiar with the tariffs & charging schemes used by local carriers…


#11

Hello AWNEIL

using AT+CGATT? shows GPRS still attached even after bearerStop … bearerClose has apparently worked as it should!
Thanks AT+CGATT=0 should do it
eg
***Port Closed By Server
[GPRS]: stop: stop GPRS interface
[GPRS]: stop: GPRS deactivate -> DISCONNECTING
[WIP] closing TCPCLIENT 0x180c4c24
[GPRS]: GPRS EVENT: 2 (cid=1)
[GPRS]: GPRS EVENT DEACTIVATE OK/KO (cid=5): -> DISCONNECTED
***Bearer Stopped
[GPRS]: close: -> CLOSED
3/7 21:24:49 0 Erbts 1 Sgnl 0 119GON0 BV3920 CV12561 L#0 trys0 0 0
at+cgatt?
+CGATT: 1
OK

So I checked after startup and the bearer is activated with no command from the application?? WIP pluggin doing this? Can this be stopped?
So after upload I stop/close the instance my application has generated but still the original instance is open I guess?
Further I have found that the APN is remembered from previous session on a restart. I close down with at+CPOF=1 and restart either with an alarm or power at the charge pin. The APN is retained and must reactivate. To prevent I have set the APN to an invalid name at shut down and this prevents the unwanted activation.


#12

Yes, I think that’s normal.

Being GPRS attached is just like being GSM attached - it means the network knows where the MS is, but is not actively engaged in any communication.
So you shouldn’t be charged for this!

Do you mean the unit is GPRS attached? That’s not the same as having a bearer activated!

Are you sure?

Only on command from the application

Check the AT Commands doc - I think there are options for “auto attach” and, possibly, automatic PDP activation…?


#13

Thnx
I had a look for auto attach/activation but haven’t been able to find anything, is it an AT command option?