# Connecting RV50 to a Cisco RV042 VPN

**URL:** <https://forum.sierrawireless.com/t/connecting-rv50-to-a-cisco-rv042-vpn/12374>\
**Category:** AirLink routers\
**Created:** [April 9, 2018, 5:26pm UTC](https://forum.sierrawireless.com/t/connecting-rv50-to-a-cisco-rv042-vpn/12374 "2018-04-09T17:26:38Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![sandjm](https://avatars.discourse-cdn.com/v4/letter/s/9d8465/32.png) [@sandjm](https://forum.sierrawireless.com/u/sandjm)\
**Post date:** [April 9, 2018, 5:26pm UTC](https://forum.sierrawireless.com/t/connecting-rv50-to-a-cisco-rv042-vpn/12374/1 "2018-04-09T17:26:38Z")

</div>

I have struggled with getting a RV50 to connect to a Cisco RV042 ipsec VPN for house now. Is there a tutorial or something that might help me out?

Background:

The RV50 has a public static ip address.  
The RV042 also has a public static ip address

I appears from the logs that the tunnel is try to connect but fails.

On the cisco the log keeps updating with this:

| Apr 9 10:20:07 2018 | VPN Log | (g2gips0) #461: [Tunnel Established] ISAKMP SA established |
| --- | --- | --- |
| Apr 9 10:20:25 2018 | VPN Log | (g2gips0) #463: [Tunnel Established] ISAKMP SA established |

The RV50 has this is the log:

Apr 9 17:02:14 err ALEOS\_VPN: ipsec\_wrapper: VPNFO is disabled due to wrong ID of primary or secondary VPN ID  
Apr 9 17:02:18 err ALEOS\_VPN: ipsec\_wrapper: VPNFO is disabled due to wrong ID of primary or secondary VPN ID  
Apr 9 17:02:22 notice ALEOS\_LINKMGMT\_linkmon: New Link Status - Network Ready  
Apr 9 17:02:22 warning ALEOS\_SERIAL\_HMC: not in tcp mode current mode 0  
Apr 9 17:02:23 alert ALEOS\_LAN: MTU Source Auto - Set DHCP option 26 MTU: 1428  
Apr 9 17:02:23 alert ALEOS\_LAN: MTU Source Auto - Ignore Opt 26 MTU size 1500  
Apr 9 17:02:29 warning ALEOS\_ALMS\_LWM2M: Failed bootstrap, retrying in ‘10’ seconds, ‘4’ left  
Apr 9 17:02:48 warning ALEOS\_ALMS\_LWM2M: Failed bootstrap, retrying in ‘20’ seconds, ‘3’ left  
Apr 9 17:03:17 warning ALEOS\_ALMS\_LWM2M: Failed bootstrap, retrying in ‘40’ seconds, ‘2’ left

Any ideas?

---

<div class="post-metadata">

**Author:** ![sandjm](https://avatars.discourse-cdn.com/v4/letter/s/9d8465/32.png) [@sandjm](https://forum.sierrawireless.com/u/sandjm)\
**Post date:** [April 9, 2018, 5:29pm UTC](https://forum.sierrawireless.com/t/connecting-rv50-to-a-cisco-rv042-vpn/12374/2 "2018-04-09T17:29:28Z")

</div>

I have double checked the PSK.

---

<div class="post-metadata">

**Author:** ![sandjm](https://avatars.discourse-cdn.com/v4/letter/s/9d8465/32.png) [@sandjm](https://forum.sierrawireless.com/u/sandjm)\
**Post date:** [April 23, 2018, 8:18pm UTC](https://forum.sierrawireless.com/t/connecting-rv50-to-a-cisco-rv042-vpn/12374/3 "2018-04-23T20:18:44Z")

</div>

Anybody? This has to be done somewhere.

---

<div class="post-metadata">

**Author:** ![jeffrussell38](https://avatars.discourse-cdn.com/v4/letter/j/ed8c4c/32.png) [@jeffrussell38](https://forum.sierrawireless.com/u/jeffrussell38)\
**Post date:** [April 24, 2018, 6:20pm UTC](https://forum.sierrawireless.com/t/connecting-rv50-to-a-cisco-rv042-vpn/12374/4 "2018-04-24T18:20:44Z")

</div>

Are you using IKEv1 or IKEv2? It appears that the RV50 is complaining that the ID is incorrect. Do you have the identity set to IP, and using the IP addresses to identify both ends?

---

<div class="post-metadata">

**Author:** ![sandjm](https://avatars.discourse-cdn.com/v4/letter/s/9d8465/32.png) [@sandjm](https://forum.sierrawireless.com/u/sandjm)\
**Post date:** [April 25, 2018, 2:50pm UTC](https://forum.sierrawireless.com/t/connecting-rv50-to-a-cisco-rv042-vpn/12374/5 "2018-04-25T14:50:04Z")

</div>

I think both the RV50 and the Cisco Rv042 support only IKEv1. Yes I am using static ip addresses on both ends.
