Calling cm at boot time


#1

Hello,

I wanted to use cm info fsn, or cm data info in init.d files but I get the following error:

root: run_getty.sh: No UART mapped to CONSOLE

Is there any solution to solve this problem?

Alain


#2

Hi Alain,
You cannot issue Legato commands prior to Legato starting up at S44.
BR,
Chris


#3

Hello Chris,

Ok but I’m starting at S90, through rc5.d so I’m supposed to execute cm after legato starting up no?

Here is the syslog. The last lines is where I execute cm:

Alain


#4

Any idea please?

Alain


#5

Hi Alain,
Can you try S90 in rcS.d? Are you certain your changes are being called properly? I don’t think rc5.d is being called.
BR,
Chris


#6

Hi Chris,
I verified how our yocto image is built:

install -d ${D}${sysconfdir}/init.d
install -d ${D}${sysconfdir}/rcS.d
install -d ${D}${sysconfdir}/rc1.d
install -d ${D}${sysconfdir}/rc2.d
install -d ${D}${sysconfdir}/rc3.d
install -d ${D}${sysconfdir}/rc4.d
install -d ${D}${sysconfdir}/rc5.d

install -m 0544 ${WORKDIR}/initscript.sh        			${D}${sysconfdir}/init.d/blackbox

ln -sf ../init.d/blackbox        ${D}${sysconfdir}/rcS.d/S90blackbox
ln -sf ../init.d/blackbox        ${D}${sysconfdir}/rc1.d/K90run-script
ln -sf ../init.d/blackbox        ${D}${sysconfdir}/rc2.d/K90run-script
ln -sf ../init.d/blackbox        ${D}${sysconfdir}/rc3.d/K90run-script
ln -sf ../init.d/blackbox        ${D}${sysconfdir}/rc4.d/K90run-script
ln -sf ../init.d/blackbox        ${D}${sysconfdir}/rc5.d/S90run-script

Do you agree with that?

And according to the log I provided in a previous post, cm command is performed after Legato started up.

Alain