BX3105 Reset Issue

My BX3105 devboard suddenly started to respond with errors to my AT commands, when I power cycle the device and hit the reset button I received the messages below on my terra term terminal:

Guru Meditation Error: Core 1 panic’ed (StoreProhibited). Exception was unhandled.
Core 1 register dump:
PC : 0x40091025 PS : 0x00060e33 A0 : 0x800921b2 A1 : 0x3ffe2710
A2 : 0x00000048 A3 : 0x00000018 A4 : 0x00000000 A5 : 0x3ffe1e68
A6 : 0x00000000 A7 : 0x00000010 A8 : 0x0000abab A9 : 0x00060e20
A10 : 0x0000cdcd A11 : 0x00000001 A12 : 0x0000abab A13 : 0xb33fffff
A14 : 0x3ffb6434 A15 : 0x3ffccc30 SAR : 0x00000000 EXCCAUSE: 0x0000001d
EXCVADDR: 0x00000048 LBEG : 0x00000000 LEND : 0x00000000 LCOUNT : 0x00000000

Backtrace: 0x40091025:0x3ffe2710 0x400921af:0x3ffe2730 0x401047fa:0x3ffe2770 0x40104a74:0x3ffe2790 0x400fe79c:0x3ffe27b0 0x400fe7c8:0x3ffe27d0 0x400f7001:0x3ffe27f0 0x400f7ed8:0x3ffe2810 0x400f584d:0x3ffe2850 0x400f264d:0x3ffe2870


Can you please suggest how this issue can be fixed?

Hi @faridm,
It seems like the module is dumped after resetting. Have you tried to get the authentic firmware back on, by booting into the bootloader. Please refer to procedure below

  • Power off module. Place a jumper on Prog. Mode Pins to pull GPIO(27) to high (source). The position is highlighted as attached image
  • Open bootloader tool (I used Hercules tools) and press reset button on the module
  • Check ACK message, the boot loader of the module should go into communication mode. The messages like this:

configsip: 0, SPIWP:0xee
mode:DIO, clock div:2
ho 12 tail 0 room 4
entry 0x40078b24
At this point, the module enter bootload mode successfully

Please share if you have any concern and help us tick Solution if your question is answered


I tried your solution and unfortunately it did not work.

When I press the reset button, I see only this message: ÀWSIH ( as it is: no A at the end)

and when I try the run the device as I should, I get back some failure error and symptoms I described before.

I run this command:

C:\Users\XXX\Documents\SierraWireless_BX310X\BX310x FW Updater v2>BX31xxBlTest.exe com5 -v
BC310x bootloader version 2.6.

Then, I tried doing a firmware upgrade, but when I try to run this command:

C:\Users\XXX\Documents\SierraWireless_BX310X\BX310x.2.7.2>BX310x.2.7.2.bin com5 -v

“I get this error: This file does not have an app associated with it for performing this action. Please install an app or, if one is already installed, create an association in the Default Apps Settings page”

any way I can do a firmware upgrade to solve this issue, or my device is just not usable any more?


Hi Guys!

Can any tech support guy get back to me about my issues above?

Thank you in advance!

I am still waiting for tech support.