Basic download instructions. Did I mess up badly?


#1

Hello,

I’m trying to get the Q52 Sample Tracking Application going on a loaner development kit. After compiling the software from the application note I tried to find out how to download it to the target. Referring to the documentation the only thing I found about downloading was the following. I didn’t find the ‘Target Management’ button until afterwards:

So, I followed that routine and assumed DWLWin was the download program. After downloading my application I went to run it and there is no response from the board at any baud rate.

There’s the history, here’s my questions.

  1. Will downloading the user app in this manner overwrite the firmware that runs the console? Is that why I have no response?
  2. Should I see the ‘target management’ application connect to the development board anyway (Target Management puts up an error message saying the serial connection is established but the target is unresponsive)?
  3. Is there a way for me to try a recovery of sorts on the Q52, so that I can start fresh?
  4. Are there any other ideas about why I get no response from the development board?
  5. Since this is a loaner board something else may have happened to it previously, what other things can I do to try and revert it to an original state.

Extra Info:

  • All software is exactly the same version as the Q52 Sample tracking application note requests.
  • DWLWin claims a sucessful download of the code
  • Tried on two different computers
  • Serial connection at 115200 8-N-1 w/ hardware flow control (but other configs have been attempted). Cable has been pinned out.
  • All jumpers for UART 1 are in place on the Q52 daughter board. (DSR was initially missing and I added it, have attempted both ways).
  • Tried both service and normal mode

#2

I don’t see any responses to your questions.

Did you manage to resolve the issue off-line?